ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

Error: ImportError: No module named rosserial_msgs.msg".

asked 2021-08-16 21:46:55 -0500

dungton gravatar image

updated 2022-05-01 13:18:38 -0500

lucasw gravatar image

Hi everyone,I have a problem running

rosrun rosserial_python serial_node.py _port:=/dev/ttyACM0 _baud:=115200

I installed rosserial package from source because i can't unlocate ros-melodic-rosserial-arduino on raspberry 4.When i running it it shows error:

File "/home/pi/catkin_ws/install/lib/python2.7/dist-packages/rosserial_python/SerialClient.py", line 53, in <module>
    from rosserial_msgs.msg import TopicInfo, Log
ImportError: No module named rosserial_msgs.msg

I tried many ways but nothing worked, please help me,thanks everyone.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2022-05-02 16:50:05 -0500

Mike Scheutzow gravatar image

If you can not install the apt package ros-melodic-rosserial-msgs, then you have to build the ros package from source. The wlki page is: https://wiki.ros.org/rosserial_msgs

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2021-08-16 21:46:55 -0500

Seen: 109 times

Last updated: May 02 '22