Ask Your Question
2

lookupTransform base_link to laser0_frame timed out. Could not transform laser scan into base_frame

asked 2012-07-10 01:46:36 -0500

pkohout gravatar image

updated 2012-07-10 01:48:31 -0500

Hi, i am just trying to use hector_mapping. But if i start it i get : lookupTransform base_link to laser0_frame timed out. Could not transform laser scan into base_frame.

i start hector_mapping like: rosrun hector_mapping hector_mapping is that wrong ??i see it often started via a .launch file.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
6

answered 2012-07-10 01:50:59 -0500

updated 2012-07-10 01:54:05 -0500

It's recommended to prepare a launch file, as it's much more cumbersome to set parameters via the command line every time you start the system. How to set the most important parameters is described in the tutorials.

In your case, it appears the frame set for the base_frame parameter does not exist in your tf tree.

edit flag offensive delete link more

Comments

thanks, after writing my own .launch file and relooking my tf_tree i changed my parameters... now i get the following:TF_OLD_DATA ignoring data from the past for frame /laser0_frame at time 1467.16 according to authority /hector_mapping what does this mean exactly ?

pkohout gravatar image pkohout  ( 2012-07-10 02:57:57 -0500 )edit

regarding your comment: It sounds like you are using two machines for your robot and they are out of synchronisation. If you use two or more machines in a ROS network always ensure that a time server is taken care about synchronising the machines.

tlinder gravatar image tlinder  ( 2012-07-10 04:01:47 -0500 )edit

ok have stet up a synch and now all works fine ..... thanks a lot

pkohout gravatar image pkohout  ( 2012-07-10 20:37:19 -0500 )edit

Should we prepare our own launch file after creating a new hector_slam package by following this tutorial? http://wiki.ros.org/ROS/Tutorials/Cre... .

bsk gravatar image bsk  ( 2016-05-13 09:29:36 -0500 )edit
0

answered 2018-10-22 19:23:37 -0500

Hobbert Evergreen gravatar image

I have the same problem and to me the solution is something about sync!!

I'm using two different computers, one with roscore and another running the LIDAR.

The computers have about 10 seconds out of sync, so with some tricks I solved it!

You can verify your current time with this command: (do this on both computers)

timedatectl

To correct the time delay between then, do the follow:

Disable the ntp service to update

sudo service ntp stop

Update

sudo ntpdate 0.ubuntu.pool.ntp.org

Enable again

sudo service ntp start

Do this on both computers

Maybe its not necessary to start and stop

Verify again if the time are now ok

timedatectl

The TIME OUT error that the message said it's a fake time out. Your messages are Ok but with wrong timestamps, so the program understands that, in my case, the message takes 10 seconds to get the other computer!

If it is your case, you can get some explanations over the topic 5 in this link about "timming issues" and how to solve it in another way: (using chrony and so far) http://wiki.ros.org/ROS/NetworkSetup

And here I got some hints about using ntp! https://askubuntu.com/questions/429306/ntpdate-no-server-suitable-for-synchronization-found

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-07-10 01:46:36 -0500

Seen: 3,776 times

Last updated: Oct 22 '18