ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

Calling install\local_setup.bat shows "The input line is too long."

asked 2021-07-29 04:35:35 -0500

Mahfuz gravatar image

updated 2021-08-08 02:05:58 -0500

I have just installed ROS2 Foxy in Windows 10 version 21H1 (OS Build 19043.1110). I followed everything step by step from Building ROS 2 on Windows . One exception was that I installed "Patch" to workaround an error that showed 1 package failed: zstd_vendor while running colcon build command. It fixed the problem. After building ros2_foxy, as instructed, after commanding call C:\dev\ros2_foxy\install\local_setup.bat, it repeatedly shows The input line is too long. I'd be grateful if anyone could help me out.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-08-08 02:01:36 -0500

Mahfuz gravatar image

updated 2021-08-08 02:03:57 -0500

Because I didn't use the attribute --merge-install the paths become too long for the local_setup.bat to work. And there is no way to override that limit as it is defined by the windows. I also checked the bat file. It doesn't repeat paths making it too long. Paths actually are too long. One way was to use short names and aliases. I didn't try that. I just deleted the C:\dev\ros2_foxy folder. Then again I imported the repos file and cloned from it and then used colcon build --merge-install. Now it is fine.

edit flag offensive delete link more

Question Tools

3 followers

Stats

Asked: 2021-07-29 04:32:10 -0500

Seen: 117 times

Last updated: Aug 08 '21