Ask Your Question
0

roscore command not found; broken packages; unable to install roslaunch

asked 2021-07-28 07:41:05 -0600

Ale gravatar image

updated 2021-07-28 07:41:59 -0600

I am working on a project in Ubuntu 20.04 remotely. I followed the documentation and installed ROS. Yet It shows few packages couldn't be downloaded and I have broken packages. When I ran the command roscore in my terminal, I got "roscore: command not found" error. I tried / installing roslaunch but got "unmet dependencies" error. Can you provide me the exact commands to get through these issues?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2021-07-28 07:59:27 -0600

Ranjit Kathiriya gravatar image

updated 2021-07-28 08:00:14 -0600

Hello Ale,

I got "roscore: command not found" error

Did you source it? source /opt/ros/<Version-of-ros>/setup.bash

Then after go to your workspace by the cd <workspace-name> command.

then build your workspace by catkin_make

Again source your local work-space by source devel/setup.bash

edit flag offensive delete link more

Comments

Did you solve this issue? If yes, then click on tick so it can be helpful to others.

Ranjit Kathiriya gravatar image Ranjit Kathiriya  ( 2021-07-28 08:41:34 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-07-28 07:41:05 -0600

Seen: 141 times

Last updated: Jul 28 '21