Ask Your Question
0

ERROR: Model Parsing the xml failed

asked 2021-07-14 06:09:56 -0500

akash12124234 gravatar image

i created a urdf file from xacro file. eventhough i got error i noticed the urdf has been created the following was the error i got.

  redefining global symbol: pi
    when processing file: /home/akash/project/src/techman_robot_ros-master/tm_grasp_description/urdf/tm700.urdf.xacro
        included from: hrwros.xacro
        akash@akash:~/project/src/tec

i have noticed the urdf file has been created so when I tried to run

    check_urdf hrwros.urdf

and this is the urdf file

<?xml version="1.0" encoding="utf-8"?>
<!-- =================================================================================== -->
<!-- |    This document was autogenerated by xacro from hrwros.xacro                   | -->
<!-- |    EDITING THIS FILE BY HAND IS NOT RECOMMENDED                                 | -->
<!-- =================================================================================== -->
<robot name="hrwros">
  <!-- world -->
  <link name="world"/>
  <!-- Links -->
  <link name="world_interface"/>
  <link name="workcell">
    <visual>
      <geometry>
        <mesh filename="package://hrwros_support/meshes/workcell/visual/workcell.dae"/>
      </geometry>
    </visual>
    <collision>
      <geometry>
        <mesh filename="package://hrwros_support/meshes/workcell/collision/workcell.dae"/>
      </geometry>
    </collision>
    <inertial>
      <inertia ixx="1.0" ixy="0" ixz="0" iyy="1.0" iyz="0" izz="1.0"/>
      <mass value="100"/>
    </inertial>
  </link>
  <joint name="workcell_to_world_interface" type="fixed">
    <parent link="world_interface"/>
    <child link="workcell"/>
    <origin rpy="0 0 1.57079632679" xyz="0 0 0"/>
  </joint>
  <joint name="robot1_pedestal_joint" type="fixed">
    <origin rpy="0 0 0" xyz="0.5 1.8 0.0"/>
    <parent link="world_interface"/>
    <child link="robot1_pedestal_link"/>
  </joint>
  <link name="robot1_pedestal_link">
    <visual>
      <origin xyz="0 0 0.475"/>
      <geometry>
        <box size="0.3 0.3 0.95"/>
      </geometry>
      <material name="pedestal_color">
        <color rgba="0 0.156862745098 0.525490196078 1"/>
      </material>
    </visual>
    <collision>
      <origin xyz="0 0 0.475"/>
      <geometry>
        <box size="0.3 0.3 0.95"/>
      </geometry>
    </collision>
    <inertial>
      <mass value="500"/>
      <origin rpy="0 0 0" xyz="0 0 0"/>
      <inertia ixx="0.001" ixy="0" ixz="0" iyy="0.001" iyz="0" izz="0.001"/>
    </inertial>
  </link>
  <gazebo reference="robot1_pedestal_link">
    <material>Gazebo/Blue</material>
  </gazebo>
  <transmission name="robot1_shoulder_1_trans">
    <type>transmission_interface/SimpleTransmission</type>
    <joint name="robot1_shoulder_1_joint">
      <hardwareInterface>PositionJointInterface</hardwareInterface>
    </joint>
    <actuator name="robot1_shoulder_1_motor">
      <mechanicalReduction>1</mechanicalReduction>
    </actuator>
  </transmission>
  <transmission name="robot1_shoulder_2_trans">
    <type>transmission_interface/SimpleTransmission</type>
    <joint name="robot1_shoulder_2_joint">
      <hardwareInterface>PositionJointInterface</hardwareInterface>
    </joint>
    <actuator name="robot1_shoulder_2_motor">
      <mechanicalReduction>1</mechanicalReduction>
    </actuator>
  </transmission>
  <transmission name="robot1_elbow_1_trans">
    <type>transmission_interface/SimpleTransmission</type>
    <joint name="robot1_elbow_1_joint">
      <hardwareInterface>PositionJointInterface</hardwareInterface>
    </joint>
    <actuator name="robot1_elbow_1_motor">
      <mechanicalReduction>1</mechanicalReduction>
    </actuator>
  </transmission>
  <transmission name="robot1_wrist_1_trans">
    <type>transmission_interface/SimpleTransmission</type>
    <joint name="robot1_wrist_1_joint">
      <hardwareInterface>PositionJointInterface</hardwareInterface>
    </joint>
    <actuator name="robot1_wrist_1_motor">
      <mechanicalReduction>1</mechanicalReduction>
    </actuator>
  </transmission>
  <transmission name="robot1_wrist_2_trans">
    <type>transmission_interface/SimpleTransmission</type>
    <joint name="robot1_wrist_2_joint">
      <hardwareInterface>PositionJointInterface</hardwareInterface>
    </joint>
    <actuator name="robot1_wrist_2_motor">
      <mechanicalReduction>1</mechanicalReduction>
    </actuator>
  </transmission>
  <transmission name="robot1_wrist_3_trans">
    <type>transmission_interface/SimpleTransmission</type>
    <joint name="robot1_wrist_3_joint">
      <hardwareInterface>PositionJointInterface</hardwareInterface>
    </joint>
    <actuator name="robot1_wrist_3_motor">
      <mechanicalReduction>1</mechanicalReduction>
    < ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2021-07-14 09:02:20 -0500

djchopp gravatar image

The error is decently descriptive of the problem. The generated URDF has the link world_interface defined twice with the line <link name="world_interface"/> appearing around line number 10 and 333.

Check your xacro to see if it defines this link multiple times. It would be better to fix the xacro, but deleting line 333 should allow you to continue.

If you want help with the issue in the xacro, please post that as well.

Hope this helps!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-07-14 06:09:56 -0500

Seen: 44 times

Last updated: Jul 14 '21