Costmap2DROS transform timeout. global_pose stamp: 0.0000

asked 2021-07-09 11:21:40 -0600

Grand gravatar image

The global_pose stamp time is always 0.0000 which throws the Costmap2DROS transform timeout warning. Any help for solving this issue would be appreciated. Some solutions online suggested time syncing each device which we have done and that has not solved this problem.

Using ROS1 on Ubuntu 20.04.

This webpage will not allow us to upload images as this is a new account, so pasted below are the global and local costmap parameter files we are using. If more information or code is needed please let us know.

global_costmap:
    global_frame: map
    robot_base_frame: base_link
    update_frequency: 10.0
    publish_frequency: 10.0
    transform_tolerance: 2.0
    static_map: true

local_costmap:
    global_frame: odom
    robot_base_frame: base_link
    update_frequency: 10.0
    publish_frequency: 10.0
    transform_tolerance: 2.0
    static_map: false
    rolling_window: true
    width: 3
    height: 3
    resolution: 0.05
edit retag flag offensive close merge delete

Comments

I'm not exactly sure what you mean by global_pose as it's not a standard term. In general, the node that generates a transform is responsible for setting the header.stamp field. If stamp is not being set, I consider that a bug.

BTW, in my experience, global_costmap and local_costmap use the same frame name for their global_frame field.

Mike Scheutzow gravatar image Mike Scheutzow  ( 2021-07-11 09:05:21 -0600 )edit

If the title of this question is the actual error message, then that probably means the Costmap2D is unable to determine the transform from map->base_link. What are you using to do localization for the robot?

Mike Scheutzow gravatar image Mike Scheutzow  ( 2021-07-11 09:22:01 -0600 )edit