Ask Your Question
0

How to change the homing order

asked 2021-07-07 10:13:02 -0600

TLZ gravatar image

Hello,

I am trying to home 3 drives in a specific order. Here akosodry asked the same question: Link to another question So what I did was specify the nodes as a list:

nodes: #The order here is important because it defines the homing order. welp it does not
  - name: joint_z
    id: 4 #node id
    dcf_overlay:
      "3202": "77"          #Motor configuration
      "6099sub1": "40000"  #Homing speed when searching for switch
      "6099sub2": "5000"    #Homing speed when searching for zero
      "3240sub1": "7"       
      "6098": "14"          #Homing method,
      "6081": "50000"       #profile velocity
      "3700": "1"           #Reaction to following error
    pos_to_device: "rint(pos*1000)" # rad -> mdeg
    pos_from_device: "obj6064/1000" # actual position [mdeg] -> rad
    vel_to_device: "rint(vel*1000)" # rad/s -> mdeg/s
    vel_from_device: "obj606C/1000" # actual velocity [mdeg/s] -> rad/s
    eff_to_device: "rint(eff)" # just round to integer
    eff_from_device: "0" # unset

  - name: joint_y
    id: 3 # node id
    dcf_overlay:
      "6099sub1": "40000"    #Homing speed when searching for switch
      "6099sub2": "5000"    #Homing speed when searching for zero
      "3240sub1": "7"       
      "6098": "10"          #Homing method
      "6081": "50000"       #profile velocity
      "3700": "1"           #Reaction to following error
      "6065": "4294967295"  #Following error surveillance deactivated
    pos_to_device: "rint(-pos*1000)" # rad -> mdeg
    pos_from_device: "-obj6064/1000" # actual position [mdeg] -> rad
    vel_to_device: "rint(-vel*1000)" # rad/s -> mdeg/s
    vel_from_device: "-obj606C/1000" # actual velocity [mdeg/s] -> rad/s
    eff_to_device: "rint(eff)" # just round to integer
    eff_from_device: "0" # unset

joint_z should be homed before joint_y, but no matter in which order I put them, joint_y always gets homed first. What am I doing wrong or is there a different solution?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2021-07-08 17:22:51 -0600

Mathias Lüdtke gravatar image

updated 2021-07-08 17:23:20 -0600

What am I doing wrong

Nothing!

Even with the list-style, the node will be sorted by name.

I just discovered this issues recently. Please try https://github.com/ros-industrial/ros...

is there a different solution?

If you want to use the release version:

You can name the node alphabetically, but set different joint names:

nodes:
  - name: motor_1
    joint: joint_z
    id: 4 #node id
edit flag offensive delete link more

Comments

Sorry for the super late reply. Thank you for the fast commit. It now works as expected.

TLZ gravatar image TLZ  ( 2021-10-21 03:29:26 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2021-07-07 10:12:03 -0600

Seen: 22 times

Last updated: Jul 08