Ask Your Question
1

PointCloud 2 data in turtlebot simulation

asked 2012-07-06 15:49:34 -0500

akhil gravatar image

updated 2012-07-12 23:54:08 -0500

karthik gravatar image

hello,

I am running turtelbot simulation and when i Use rviz to visualize pointcloud2 data than it gives incorrect point cloud . How i can fix this? any tips would be appreciated As i am new to ros.

In the world image there is no object just in front of the robot but rviz shows some points there ,also when i try to run the robot this "patch" of ploint cloud keeps moving along with the robot .

because of this I am not able to build the correct octomap as it uses pointclud2 data.


I observed that the pointcloud is not forming correctly. Even the clouds of the ground are shown as walls. Below is the pic of the situation with both world and rviz view of the pointclouds. Any help here is appreciated!!! My situation is shown in the attachments.

gazebo) rviz


Problem not with the frame of reference but with the pointcloud simulated from the gazebo. It looks like a bug. Any suggestion to overcome this is appreciated!!!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-07-07 05:53:21 -0500

dornhege gravatar image

Your fixed frame is wrong. It is set to the camera frame, thus it keeps moving. You should set it to an actual frame that is fixed in the world, as e.g. /map or /odom. That depends if you have some kind of localization or SLAM.

edit flag offensive delete link more

Comments

hey, thanks for your reply but i have already tried /map and /odom but still the point cloud is incorrect

akhil gravatar image akhil  ( 2012-07-07 06:12:07 -0500 )edit

By watching above rviz pic I think that the point cloud is not moving with robot, it's actually the point cloud of the floor which comes inside of the camera's frustum but it's being displayed in the wrong direction

akhil gravatar image akhil  ( 2012-07-07 06:12:25 -0500 )edit

I have to admit I can't really match the pointcloud in your image with anything in the world. A bug that just flattens everything seems very weird to me. Did you try driving towards a corner.

dornhege gravatar image dornhege  ( 2012-07-13 00:04:40 -0500 )edit

i tried driving towards the corner and i get the point cloud of the two walls but the point cloud of the floor is shown in the same plane as walls the same thing is happening in the image shown

akhil gravatar image akhil  ( 2012-07-13 18:53:38 -0500 )edit

In that case there is definitely something wrong. I'd suggest following up on Stefan's hints.

dornhege gravatar image dornhege  ( 2012-07-16 01:15:13 -0500 )edit
0

answered 2012-07-13 01:44:20 -0500

This looks like a potential graphics card issue (gazebo is a bit picky in that regard sometimes). I have a colleague who can't use the simulated Kinect because he has onboard Intel graphics in his machine and the same happens for him. See also this Q/A.

edit flag offensive delete link more

Comments

hey, thanks for your reply i am also using the intel graphics card on my laptop can you suggest what should i do to fix this problem i also have nvidia graphics card on my machine and tried to install the driver for it but my ubuntu crashed and i had to reinstall it

akhil gravatar image akhil  ( 2012-07-13 18:54:23 -0500 )edit

Ok, so you're using Optimus tech most likely. Have a look at this Q/A: http://answers.ros.org/question/36430/gazebo-dead-slow-on-8x27ghz-cpu-with-a-nvidia/ . From what I heard, recent Bumblebee version worked well for some people.

Stefan Kohlbrecher gravatar image Stefan Kohlbrecher  ( 2012-07-14 13:31:18 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-07-06 15:49:34 -0500

Seen: 1,189 times

Last updated: Jul 13 '12