ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
0

Problem with dependencies when installing ros-noetic

asked 2021-06-07 13:46:23 -0600

regoGr gravatar image

I remove ROS noetic and now I'm trying to reinstall ros-noetic on Ubuntu 20.04. I followed instructions in tutorial: http://wiki.ros.org/noetic/Installati... When I did it, I receive this error:

The following packages have unmet dependencies: ros-noetic-desktop-full:
Depends: ros-noetic-common-tutorials but it is not going to be installed
Depends: ros-noetic-joint-state-publisher-gui but it is not going to be installed
Depends: ros-noetic-robot but it is not going to be installed
Depends: ros-noetic-ros-tutorials but it is not going to be installed
Depends: ros-noetic-urdf-tutorial but it is not going to be installed Depends: ros-noetic-visualization-tutorials but it is not going to be installed
Depends: ros-noetic-viz but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I tried to find solution and looked here and here, but it didn't work. What did I do wrong?

edit retag flag offensive close merge delete

Comments

1

but it didn't work

What does this mean? What happened?

jayess gravatar image jayess  ( 2021-06-07 16:09:15 -0600 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2021-06-08 02:53:00 -0600

Gates gravatar image

It simply means that there are some packages which are not installed.

One way is to install packages manually deeper and deeper. Let say, don't install ros-noetic-desktop-full first but install ros-noetic-visualization-tutorials first, then ros-noetic-ros-tutorials, then ros-noetic-urdf-tutorial etc.

If you cannot install these, the problem might be about setting the keys. Have you computed this: sudo apt-key adv --keyserver 'hkp://keyserver.ubuntu.com:80' --recv-key C1CF6E31E6BADE8868B172B4F42ED6FBAB17C654 ? and then sudo apt update.

edit flag offensive delete link more

Comments

Yes, I did all of instructions. I computed key and made update. When I tried to install packages manually I received more and more packages which cannot install. Do you thing what the problem is due to one packages? When I deleted ROS I did autoremove. May be some important dependencies was deleted?

regoGr gravatar image regoGr  ( 2021-06-08 04:32:31 -0600 )edit

After entering its product it showed: Executing: /tmp/apt-key-gpghome.2rzZXNEMFZ/gpg.1.sh –keyserver hkp://keyserver.ubuntu.com:80 –recv-key C1CF6E31E6BADE8868B172B4F42ED6FBAB17C654
gpg: key F42ED6FBAB17C654: “Open Robotics info@osrfoundation.org” not changed
gpg: Total number processed: 1
gpg: unchanged: 1

May be it is due I did it yesterday.

regoGr gravatar image regoGr  ( 2021-06-08 04:52:25 -0600 )edit

Have you tried sudo apt update and sudo apt upgrade (both) after setting the key? Then try to sudo aptitude install ros-noetic-desktop-full

Gates gravatar image Gates  ( 2021-06-08 05:40:21 -0600 )edit

Thank you! sudo aptitude install ros-noetic-desktop-full helped me. This caused another problem but it is another story.

regoGr gravatar image regoGr  ( 2021-06-08 11:03:07 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-06-07 13:46:23 -0600

Seen: 774 times

Last updated: Jun 08 '21