Ask Your Question
0

Error building mmwave_ti_ros: ‘MyPointType’ was not declared in this scope

asked 2021-05-20 01:43:02 -0500

Aleena gravatar image

updated 2021-05-20 09:16:33 -0500

gvdhoorn gravatar image

Hello, I am using ROS for ROS point cloud visualizer with IWR6843ISK. I a using Oracle VB Ubuntu 18.04LTS.First time installation and building packages were successfully build. But I had to reset my VM . After that whenever I build the package error is showing. I have copied the error showed in terminal. Please help. I had gone through many Q and A. But I could't find nothing. I have reinstalled everything many times. Nothing went right. Thanks in advance. Thanks and regards, Aleena NA

Base path: /home/logiqdreams/mmwave_ti_ros/ros_driver
Source space: /home/logiqdreams/mmwave_ti_ros/ros_driver/src
Build space: /home/logiqdreams/mmwave_ti_ros/ros_driver/build
Devel space: /home/logiqdreams/mmwave_ti_ros/ros_driver/devel
Install space: /home/logiqdreams/mmwave_ti_ros/ros_driver/install
Creating symlink "/home/logiqdreams/mmwave_ti_ros/ros_driver/src/CMakeLists.txt" pointing to "/opt/ros/melodic/share/catkin/cmake/toplevel.cmake"
####
#### Running command: "cmake /home/logiqdreams/mmwave_ti_ros/ros_driver/src -DCATKIN_DEVEL_PREFIX=/home/logiqdreams/mmwave_ti_ros/ros_driver/devel -DCMAKE_INSTALL_PREFIX=/home/logiqdreams/mmwave_ti_ros/ros_driver/install -G Unix Makefiles" in "/home/logiqdreams/mmwave_ti_ros/ros_driver/build"
####
-- The C compiler identification is GNU 7.5.0
-- The CXX compiler identification is GNU 7.5.0
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Using CATKIN_DEVEL_PREFIX: /home/logiqdreams/mmwave_ti_ros/ros_driver/devel
-- Using CMAKE_PREFIX_PATH: /opt/ros/melodic
-- This workspace overlays: /opt/ros/melodic
-- Found PythonInterp: /usr/bin/python2 (found suitable version "2.7.17", minimum required is "2") 
-- Using PYTHON_EXECUTABLE: /usr/bin/python2
-- Using Debian Python package layout
-- Using empy: /usr/bin/empy
-- Using CATKIN_ENABLE_TESTING: ON
-- Call enable_testing()
-- Using CATKIN_TEST_RESULTS_DIR: /home/logiqdreams/mmwave_ti_ros/ros_driver/build/test_results
-- Found gtest sources under '/usr/src/googletest': gtests will be built
-- Found gmock sources under '/usr/src/googletest': gmock will be built
-- Found PythonInterp: /usr/bin/python2 (found version "2.7.17") 
-- Looking for pthread.h
-- Looking for pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE  
-- Using Python nosetests: /usr/bin/nosetests-2.7
-- catkin 0.7.29
-- BUILD_SHARED_LIBS is on
-- BUILD_SHARED_LIBS is on
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- ~~  traversing 2 packages in topological order:
-- ~~  - serial
-- ~~  - ti_mmwave_rospkg
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- +++ processing catkin package: 'serial'
-- ==> add_subdirectory(serial)
-- +++ processing catkin package: 'ti_mmwave_rospkg'
-- ==> add_subdirectory(ti_mmwave_rospkg)
-- Using these message generators: gencpp;geneus;genlisp;gennodejs;genpy
-- Boost version: 1.65.1
-- Checking for module 'eigen3'
--   Found eigen3, version 3.3.4
-- Found eigen: /usr/include/eigen3  
-- Boost version: 1.65.1
-- Found the following Boost libraries:
--   system
--   filesystem
--   thread
--   date_time
--   iostreams
--   serialization
--   chrono
--   atomic
--   regex
-- Checking for module 'libopenni'
--   Found libopenni, version 1.5.4.0
-- Found openni: /usr/lib/libOpenNI ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2021-05-20 01:58:56 -0500

gvdhoorn gravatar image

updated 2021-05-20 02:16:07 -0500

Edit 3: it's more likely the following is the problem (from here):

POINT_CLOUD_REGISTER_POINT_STRUCT (MyPointType,
                                    (float, x, x)
                                    (float, y, y)
                                    (float, z, z)
                                    (float, intensity, intensity)
                                    (float, velocity, velocity))

It doesn't appear MyPointType is defined anywhere in that package, so the compiler is correct to complain about it.

This is a problem with the code provided by Texas Instruments.

I'd suggest to contact them and ask them for support.


Edit 2: ah, TI didn't use find_package(PCL ... EXACT), so CMake is happy with anything at least version 1.7.2, which 1.8.x of course is:

Found PCL: ... Required is at least version "1.7.2"

But again: it could be something else is the real cause, and the version difference is a red herring.


Edit: I just found what appears to be the official Git repository hosted by Texas Instruments themselves: git.ti.com/mmwave_radar/mmwave_ti_ros. The files there also seem to suggest PCL 1.7.2 is a requirement (from here):

find_package(PCL 1.7.2 REQUIRED)

I'm not really sure how this is all supposed to work, as on Ubuntu Bionic (18.04), libpcl-dev is at version 1.8.x. TI claims Bionic is compatible with their ROS package though, which clearly states the 1.7.2 version requirement.

There may be some other problem preventing you from building their driver.

I'd probably still suggest to contact TI and ask them for support. It's their product after all.


In this part of the error message:

In file included from /usr/include/pcl-1.8

we see you have PCL version 1.8.x installed.

The versions of ti_mmwave_rospkg I can find online (such as radar-lab/ti_mmwave_rospkg and ibcn-cloudlet/ti_mmwave_rospkg), seem to suggest ti_mmwave_rospkg needs PCL version 1.7.2. See fi (from radar-lab/ti_mmwave_rospkg/CMakeLists.txt):

find_package(PCL 1.7.2 REQUIRED)

I'm curious how you got things to build on your system, as I would have expected a CMake error telling you that it can't find version 1.7.2 of PCL, and then aborts the build.

It's likely your compilation problem is caused by this version mismatch. You'll have to ask Texas Instruments about this, or fix the problem yourself.

edit flag offensive delete link more

Comments

Okay, Let me try.

Aleena gravatar image Aleena  ( 2021-05-20 02:03:54 -0500 )edit

Hai, Thank you for your quick response. I have contacted them. But not received a response yet. Thank you

Aleena gravatar image Aleena  ( 2021-05-20 06:39:53 -0500 )edit

Hello, The issue was resolved. It was a bug related to repository. They have cleared it and when updated building the package was successful. Thank you

Aleena gravatar image Aleena  ( 2021-05-20 13:00:48 -0500 )edit
1

Good to hear.

gvdhoorn gravatar image gvdhoorn  ( 2021-05-20 13:10:14 -0500 )edit

Could you please mark the question as answered by ticking the checkmark to the left of the question, if you feel it has been answered?

It should turn green.

Be sure to click on the checkmark left to the answer, not a comment.

gvdhoorn gravatar image gvdhoorn  ( 2021-05-22 02:49:24 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-05-20 01:43:02 -0500

Seen: 77 times

Last updated: May 20