How to do obstacle avoidance using op local planner in Autoware 1.12 with Gazebo7.

asked 2021-05-19 00:29:19 -0500

ashokm gravatar image

updated 2021-05-19 11:16:07 -0500

OS : Ubuntu 16.04 Gazebo version - 7.0 ROS - Kinetic Autoware version - 1.12

To detect obstacles via LIdar, I am using lidar_euclidean_cluster_detect along with lidar_kf_contour_track which is publishing /tracked_objects. Op_motion_predictor is subscribing the /tracked_objects. I have seen objects data is coming in this topic and able to visualize obstacle contours in rviz.

I have placed a obstacle left side of road. op_local_planner is not stopping or not selecting different path. And I am not using any occupancy grid generation nodes.

Please help if something is wrong, what is the right way to do?

edit retag flag offensive close merge delete

Comments

Hi, i am also facing a similar issue. OP_local_planner fails to detect obstacles but when a point is published in rviz, the planner detects the obstacle. I thought the problem was with /tracked_objects published to world frame. If you find a solution, plz let me know

vivekgouravs gravatar image vivekgouravs  ( 2021-06-10 12:08:03 -0500 )edit

Please don't use an answer to ask a question. This isn't a forum. Please create a new question and reference this one (this will give your issue more visibility)

jayess gravatar image jayess  ( 2021-06-10 18:02:19 -0500 )edit