Ask Your Question
1

how to set gazebo /clock publish rate foxy

asked 2021-05-14 22:39:30 -0500

johnconn gravatar image

I followed the instructions here to launch my gazebo, and something like this used to be working for me: gazebo -s libgazebo_ros_init.so __params:=/tmp/params.yaml

but at some point (I am thinking when I migrated to foxy), this stopped working.

How do I set the /clock topic publish rate in foxy?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2021-05-14 23:18:51 -0500

johnconn gravatar image

okay I should have tried harder to find the new foxy param file syntax because it is what i needed:

gazebo -s libgazebo_ros_init.so --ros-args --params-file /tmp/params.yaml

the terminal output complains about this

Error [parser.cc:403] Error parsing XML in file [/tmp/params.yaml]: Error document empty.

but it still makes the publish rate change

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2021-05-14 22:39:30 -0500

Seen: 27 times

Last updated: May 14