ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
1

move_group/monitored_planning_scene has low frequency

asked 2021-04-26 03:03:18 -0500

berntyy gravatar image

Hi all,

I'm using Rviz to record the motion of collision objects that are attached and detached from the robot.

The attaching and detaching is working perfectly, but I'm however experiencing a lag when using move_group/monitored_planning_scene has "Planning Scene Topic". Using rostopic hz move_group/monitored_planning_scene I get that the topic is displayed with 4 Hz.

RobotModel has very smooth motion for the robot and /planning_scene has smooth motion for the objects as "Planning Scene Topic", but when using those settings the attached objects are not displayed..

Does anyone know how to increase the frequency of move_group topic, or some workaround for increasing the frequency of the displayed object in Rviz?

Thanks in advance!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2023-01-17 03:58:56 -0500

umsy gravatar image

updated 2023-01-17 04:07:19 -0500

I had a similar issue as well. If I understand your question correctly, you want the planning scene topic to be published at a higher frequency. I solved it by changing the parameter "publish_planning_scene_hz" in the "move_group" node . It was set to 4Hz by default.

You can do this from the command line using:

ros2 param set /move_group publish_planning_scene_hz 30.0

or via the launch file by passing the following as a parameter to the move_group node

{'publish_planning_scene_hz': 30.0}

Hope that helps

edit flag offensive delete link more

Comments

Very nice answer.

Mike Scheutzow gravatar image Mike Scheutzow  ( 2023-01-17 08:19:11 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2021-04-26 03:03:18 -0500

Seen: 151 times

Last updated: Jan 17 '23