ros melodic python versions conflict (--unmet dependencies)

asked 2021-04-25 11:24:05 -0500

Suman gravatar image

I have ROS-Melodic installed on my Ubuntu 18.04. It comes with python2.7 by default. And I installed python3.8 using the following steps by mistake -

wget https://www.python.org/ftp/python/3.8.0/Python-3.8.0.tgz
tar xzf Python-3.8.0
cd Python-3.8.0
sudo ./configure --enable-optimizations
sudo make altinstall
sudo apt update
sudo apt install build-essential zlib1g-dev libncurses5-dev libgdbm-dev libnss3-dev libssl-dev libreadline-dev libffi-dev wget
sudo make altinstall

After that, whatever I install or update on my terminal, it gives me Unmet Dependencies error -

$ sudo apt-get update && sudo apt-get upgrade
Hit:1 http://mirrors.piconets.webwerks.in/ubuntu-mirror/ubuntu bionic InRelease
Hit:2 http://mirrors.piconets.webwerks.in/ubuntu-mirror/ubuntu bionic-updates InRelease
Hit:3 https://download.docker.com/linux/ubuntu bionic InRelease                    
Hit:4 http://mirrors.piconets.webwerks.in/ubuntu-mirror/ubuntu bionic-backports InRelease
Hit:5 http://mirrors.piconets.webwerks.in/ubuntu-mirror/ubuntu bionic-security InRelease
Hit:6 http://ppa.launchpad.net/deadsnakes/ppa/ubuntu bionic InRelease              
Hit:7 http://dl.google.com/linux/chrome/deb stable InRelease                       
Hit:8 http://dl.winehq.org/wine-builds/ubuntu bionic InRelease                     
Hit:9 http://ppa.launchpad.net/fingerprint/fingerprint-gui/ubuntu bionic InRelease 
Hit:10 https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease
Hit:11 http://ppa.launchpad.net/micahflee/ppa/ubuntu bionic InRelease              
Hit:12 http://ppa.launchpad.net/openshot.developers/ppa/ubuntu bionic InRelease    
Hit:13 http://packages.ros.org/ros/ubuntu bionic InRelease                         
Hit:14 http://wiki.jderobot.org/apt bionic InRelease                     
Reading package lists... Done                       
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
bzr : Depends: python:any
cython : Depends: python (< 2.8) but 3.8.0-1 is installed
      Depends: python:any (< 2.8)
      Depends: python:any (>= 2.7.5-5~)
googletest : Depends: python:any
libboost-mpi-python1.65.1 : Depends: python (< 2.8) but 3.8.0-1 is installed
                         Depends: python:any (< 2.8)
                         Depends: python:any (>= 2.7.5-5~)
mercurial : Depends: python (< 2.8) but 3.8.0-1 is installed
         Depends: python:any (< 2.8)
         Depends: python:any (>= 2.7~)
mercurial-common : Depends: python:any (< 2.8)
                Depends: python:any (>= 2.7.5-5~)
python-all : Depends: python (= 2.7.15~rc1-1) but 3.8.0-1 is installed
python-all-dev : Depends: python (= 2.7.15~rc1-1) but 3.8.0-1 is installed
python-asn1crypto : Depends: python:any (< 2.8)
                 Depends: python:any (>= 2.7.5-5~)
python-attr : Depends: python:any (< 2.8)
           Depends: python:any (>= 2.7.5-5~)
python-autobahn : Depends: python:any (< 2.8)
               Depends: python:any (>= 2.7.5-5~)
python-automat : Depends: python:any (< 2.8)
              Depends: python:any (>= 2.7.5-5~)
python-backports.functools-lru-cache : Depends: python:any (< 2.8)
                                    Depends: python:any (>= 2.7.5-5~)
python-bzrlib : Depends: python (< 2.8) but 3.8.0-1 is installed
             Depends: python:any (>= 2.6.6-7~)
python-cairo : Depends: python (< 2 ...
(more)
edit retag flag offensive close merge delete