Ask Your Question
0

How to set the max distance of rtabmap?

asked 2021-04-15 08:10:42 -0500

mmaissan gravatar image

Hello,

First, I am new to ROS. I have an nVidia Jetson with a Stereolabs ZED2. I try to build a map using rtabmap. I follow these steps to get it to work. The result is as follows:

image description

However, I try to generate a map with a bigger range. I want the range to be similar to the size of the PointCloud2 topic. Right now, the octomap_grid only shows ~5 meters. I would prefer it to increase the mapping process and the shown map closer to 10 or 15 meters.

I changed the following parameters in rtabmap.launch:

<node unless="$(arg stereo)" pkg="rtabmap_ros" type="rgbd_odometry" name="rgbd_odometry" output="$(arg output)" args="$(arg rtabmap_args) $(arg odom_args)" launch-prefix="$(arg launch_prefix)">
    <param name="Vis/MaxDepth" type="string" value="20"/>
    ....
</node>

<node name="rtabmap" pkg="rtabmap_ros" type="rtabmap" output="$(arg output)" args="$(arg rtabmap_args)" launch-prefix="$(arg launch_prefix)">
     <param name="Vis/MaxDepth" type="string" value="20"/>
    ....
</node>

This does not seem to affect anything. What can I do to increase the size of the map?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2021-04-16 02:05:59 -0500

mmaissan gravatar image

After further investigating other launch files, I noticed that they contain another parmeter:

<param name="Grid/RangeMax" type="string" value="20" />

I added this and now it works.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-04-15 08:10:42 -0500

Seen: 59 times

Last updated: Apr 16