Ask Your Question
0

xv-11-lidar cannot find the right port

asked 2021-04-14 22:41:40 -0500

golferGuy1145 gravatar image

I am using ubuntu mate 20.04 focal and i have installed ros noetic, i'm following the following tutorial http://wiki.ros.org/xv_11_laser_drive...

when i try to run the following command

rosrun xv_11_laser_driver neato_laser_publisher port_:=/dev/ttyACM0

I get the following error: [ERROR] [1582038870.703246684]: Error instantiating laser object. Are you sure you have the correct port and baud rate? Error was open: No such file or directory

in the tutorial when i try to run the following command it says "error file doesn't exist"

echo 'SUBSYSTEMS=="usb", KERNEL=="ttyUSB[0-9]*", ATTRS{idVendor}=="0403", ATTRS{idProduct}=="6001", SYMLINK+="sensors/ftdi_%s{serial}"' > /etc/udev/rules.d/52-ftdi.rules

when i change 52-ftdi.rules to the actual file that is in the rules.d folder which is 70-snap.snapd.rules it says "permission denied"

when i run dmesg -w i get the following output usb 1-1.2: Product: USB Serial usb 1-1.2: Manufacturer: Teensyduino usb cdc_acm 1-1.2:1.0 ttyACM0: USB ACM device

when i run lsusb i get the following Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 001 Device 004: ID 046d:c077 Logitech, Inc. M105 Optical Mouse Bus 001 Device 003: ID 1a2c:2124 China Resource Semico Co., Ltd Bus 001 Device 008: ID 16c0:0483 Van Ooijen Technische Informatica Teensyduino Serial Bus 001 Device 007: ID 046d:0892 Logitech, Inc. OrbiCam Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

i'm not sure if the problem is because the rosrun instruction isn't getting the right port? if this is the problem then how do i change the permissions in the 70-snap.snapd.rules file? or if the problem is due to something else?

the lidar does turn when i plug it in and as far as i can tell it's not a hardware issue.....

please help me

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-04-15 10:53:16 -0500

miura gravatar image

You may not have enough permission to execute the device file. ( /dev/ttyACM0 exists, but cannot be opened from neato_laser_publisher )

$ sudo chmod 666 /dev/ttyACM0

and then run

$ rosrun xv_11_laser_driver neato_laser_publisher port_:=/dev/ttyACM0

You can also try

edit flag offensive delete link more

Comments

i tried running sudo chmod 666 /dev/ttyACM0

but it still gave me the same error

golferGuy1145 gravatar image golferGuy1145  ( 2021-04-15 13:05:43 -0500 )edit

$ ls /dev/tty*

What do you see when you do this? Does /dev/ttyACM0 or /dev/ttyUSB0 exist?

miura gravatar image miura  ( 2021-04-15 22:42:32 -0500 )edit
1

it worked after i ran sudo chmod 666 /dev/ttyACM0 and then re-did a catkin_make so thanks

golferGuy1145 gravatar image golferGuy1145  ( 2021-04-16 14:37:04 -0500 )edit

However, when i run rosrun rviz rviz it's not showing any output from the lidar which so i'm not sure what that means?

golferGuy1145 gravatar image golferGuy1145  ( 2021-04-16 15:46:29 -0500 )edit

You will need to configure rviz. Add the scan topic display. This is becoming different from the original question, so please create another question if this comment does not solve the problem.

ref : http://wiki.ros.org/rviz/UserGuide#Di...

miura gravatar image miura  ( 2021-04-16 23:00:06 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-04-14 22:41:40 -0500

Seen: 75 times

Last updated: Apr 15 '21