Ask Your Question
0

-joint-state-publisher-gui not available even after installation in RVIZ

asked 2021-03-17 12:26:16 -0600

duttonide gravatar image

updated 2021-06-07 16:12:42 -0600

jayess gravatar image

Hello, I have not been able to visualize joint_state_publisher in the RVIZ gui, even after keeping use_gui and value as true as follows:

<node name="joint_state_publisher" pkg="joint_state_publisher" type="joint_state_publisher">
        <param name="use_gui" value="True"/>
    </node>

Then I tried installing the joint_state_publisher_gui installer for the noetic to solve the issue using the following commands:

sudo apt update
sudo apt install ros-noetic-joint-state-publisher-gui

The output I got in the terminal is following:

ros-noetic-joint-state-publisher-gui is already the newest version (1.15.0-1focal.20210112.092212).

When I launched the RVIZ file again, the joint_state_publisher tool was not available and I can't use it. I also looked if it was hiding behind but not so, kindly help me out if possible. Thanks in advance. Good day.

edit retag flag offensive close merge delete

Comments

1

I have not been able to visualize joint_state_publisher in the RVIZ gui [..] When I launched the RVIZ file again, the joint_state_publisher tool was not available and I can't use it

please refrain from paraphrasing errors or warnings.

Include a verbatim copy-paste of any errors or warnings you see on the console.

Either the GUI is started or it isn't. But right now we have no way of finding out which of the options it is.

gvdhoorn gravatar image gvdhoorn  ( 2021-03-18 04:03:25 -0600 )edit

I have the same problem. There is neither warnings nor errors, just not an available joint-state-publisher-gui window. Have you resolved it now?

Dorthyn gravatar image Dorthyn  ( 2021-06-06 22:42:56 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2021-06-07 00:55:09 -0600

Dorthyn gravatar image

It seems that "use_gui" parameter is not supported in Noetic. The following is what I find in the forum: pls refer to this.

"you should install the 'joint_state_publisher_gui' package instead and run that. This backwards compatibility option will be removed in Noetic."

Your launch file is all right in Kinetic and before, but that parameter has been removed in Noetic. So if you wanna show its window, just open a new terminal with the workplace source bash and run:

Rosrun joint_state_publisher_gui joint_state_publisher_gui

Then you will see it works.

edit flag offensive delete link more
0

answered 2021-03-17 13:05:59 -0600

rafamrtq gravatar image

Try to source again: source /opt/ros/noetic/setup.bash

edit flag offensive delete link more

Comments

Sourcing changes the roscd to default noetic source file and the workspace can't be launched. Here is the following error I got:

RLException: [rviz.launch] is neither a launch file in package [mrm_description] nor is [mrm_description] a launch file name
The traceback for the exception was written to the log file
duttonide gravatar image duttonide  ( 2021-03-18 02:14:50 -0600 )edit

then try to source your catkin workspace again mrm_description

rafamrtq gravatar image rafamrtq  ( 2021-03-18 12:08:19 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-03-17 12:26:16 -0600

Seen: 589 times

Last updated: Jun 07 '21