(rviz) Segmentation fault with nvidia drivers

asked 2021-03-07 10:21:15 -0500

clover32 gravatar image

Hi. So in short i had a working environment and then i had to install NVIDIA drivers which broke everything. I manged to fix my dockerfile but my native install still doesn't work. I'm using ARCH, with a ryzen 3800x and GTX 1650. glxgears works like a charm too, so i don't think libGL is the problem. I've tried everything in the rviz troubleshoot page, but nothing worked. Basic glxinfo:

$ glxinfo | grep version
server glx version string: 1.4
client glx version string: 1.4
GLX version: 1.4
OpenGL core profile version string: 4.6.0 NVIDIA 460.56
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL version string: 4.6.0 NVIDIA 460.56
OpenGL shading language version string: 4.60 NVIDIA
OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 460.56
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
    GL_EXT_shader_group_vote, GL_EXT_shader_implicit_conversions,

GDB Debug of rviz:

$ gdb rviz 
GNU gdb (GDB) 10.1
Copyright (C) 2020 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
Find the GDB manual and other documentation resources online at:

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from rviz...
(No debugging symbols found in rviz)
(gdb) run
Starting program: /opt/ros/melodic/bin/rviz 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[New Thread 0x7fffefbff640 (LWP 458531)]
[New Thread 0x7fffee2ff640 (LWP 458532)]
[New Thread 0x7fffedafe640 (LWP 458533)]
[ INFO] [1615133166.153832875]: rviz version 1.13.15
[ INFO] [1615133166.153850545]: compiled against Qt version 5.15.2
[ INFO] [1615133166.153859255]: compiled against OGRE version 1.9.0 (Ghadamon)
[New Thread 0x7fffecde6640 (LWP 458535)]
[New Thread 0x7fffdffff640 (LWP 458536)]
[New Thread 0x7fffdf7fe640 (LWP 458537)]
[New Thread 0x7fffdeffd640 (LWP 458538)]
[ INFO] [1615133166.158734636]: Forcing OpenGl version 0.
[New Thread 0x7fffde7fc640 (LWP 458539)]
[New Thread 0x7fffca0f5640 (LWP 458540)]
[New Thread 0x7fffc98f4640 (LWP 458541)]
[New Thread 0x7fffc90f3640 (LWP 458542)]
[New Thread 0x7fffc88f2640 (LWP 458543)]
[New Thread 0x7fffaffff640 (LWP 458544)]
[New Thread 0x7fffaf7fe640 (LWP 458545)]
[New Thread 0x7fffa6ffd640 (LWP 458546)]
[New Thread 0x7fffaeffd640 (LWP 458547)]
[New Thread 0x7fffae7fc640 (LWP 458548)]
[New Thread 0x7fffadffb640 (LWP 458549)]
[New Thread 0x7fffad7fa640 (LWP 458550)]
[New Thread 0x7fffacff9640 (LWP 458551)]
[New Thread 0x7fffa7fff640 (LWP 458552)]
[New Thread 0x7fffa77fe640 (LWP 458553)]
[New Thread 0x7fffa67fc640 (LWP 458554)]
[New Thread 0x7fffa5ffb640 (LWP 458555)]
[ INFO] [1615133166.732615719]: Stereo is NOT SUPPORTED
[ INFO] [1615133166.732649419]: OpenGl version: 4,6 (GLSL 4,6).
--Type <RET> for more, q to quit, c to continue without paging--c

Thread 1 "rviz" received ...
edit retag flag offensive close merge delete


Any new insights on this? I think I am facing the exact same issue as you.

Can you give any details on your previous working environment?

Update: So I resolved my issue by switching to ROS Noetic as well as adding the arch4edu repository from the installation instructions. Everything is running great so far.

JonaL gravatar image JonaL  ( 2021-04-20 10:43:11 -0500 )edit