Ask Your Question
0

Unable to locate package ros-dashing-acado-vendor

asked 2021-03-03 02:45:41 -0500

guillermoherreraf gravatar image

updated 2021-03-08 01:50:17 -0500

Hello! I'm installing Autoware.Auto on a NVIDIA Jetson AGX from source. When I run the command to install the dependencies: rosdep install -y -i --from-paths src, I get the following message:

ERROR: the following rosdeps failed to install

apt: command [sudo -H apt-get install -y ros-dashing-acado-vendor] failed

I tried to search online what this package does, and if it is vital to have Autoware.Auto running. However, I could not find any information about it. Will I be able to use all the functionalities of Autoware.Auto without this package?

Update: Apparently it is important. I tried to build with colcon build in the AutowareAuto workspace and I get the following messages:

1 package had stderr output: mpc_controller

41 packages not processed

Any idea how to solve this isuue?

edit retag flag offensive close merge delete

Comments

I'm sorry to have to do this for something so seemingly unimportant, but please don't post screenshots of terminal text in question on ROS Answers. It's all text, so there is no need. Just copy-paste the text from the terminal into your question text. Do make sure to format it properly by selecting the text and pressing ctrl+k (or clicking the Preformatted Text button (the one with 101010 on it)).

You don't need to post a new question, just edit your curent one. You can use the edit button/link for this.

After you replace the screenshot with the error message itself, we can re-open your question.

gvdhoorn gravatar image gvdhoorn  ( 2021-03-03 04:07:00 -0500 )edit

I will answer the problem after you fix this.

Josh Whitley gravatar image Josh Whitley  ( 2021-03-06 11:52:04 -0500 )edit

Already edited the question, sorry about that!

guillermoherreraf gravatar image guillermoherreraf  ( 2021-03-08 01:50:38 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2021-03-08 05:08:39 -0500

fredBeauj gravatar image

@guillermoherreraf Acado was recently moved into a separate project in this MR and Autoware.Auto only supports dashing up to the release 1.0.0, from your error message, I guess you use dashing?

Are you installing the latest master version? Perhaps you give the released version a try;e.g., this commit

In any case, I would check to make sure you start from a clean slate if you have by now tried various things in your workspace

edit flag offensive delete link more

Comments

1

Hello @fredBeauj. Yes I am using Dashing, as I'm running the Autoware stack in a Jetson AGX which comes with Ubuntu 18.04. And yes I installed the master version of Autoware,Auto. I managed to make the stack compile by installing the acado_vendor package from source, as @sgermanserrano suggested. I'm trying to run the simple trajectory test in alongside the simulator; however, I appreciate some strange behavior. I think I will open another issue to address that.

guillermoherreraf gravatar image guillermoherreraf  ( 2021-03-08 06:19:41 -0500 )edit
0

answered 2021-03-03 03:51:53 -0500

sgermanserrano gravatar image

@guillermoherreraf have you done apt update before trying to install via rosdep? The package appears as released for dashinghttps://index.ros.org/p/acado_vendor/.... Worst case scenario you can get it from source https://gitlab.com/autowarefoundation...

edit flag offensive delete link more

Comments

Hello @sgermanserrano. Yes, I ran apt update beforehand. I will see if installing it from source works.

guillermoherreraf gravatar image guillermoherreraf  ( 2021-03-03 03:56:09 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-03-03 02:45:41 -0500

Seen: 174 times

Last updated: Mar 08 '21