zsh: permission denied: ros2

asked 2021-02-26 12:34:32 -0500

kaybug gravatar image

updated 2021-02-28 10:50:10 -0500

I'm running macOS 11.1 and trying to install ROS2 Eloquent. I have followed the tutorial on index.ros.org. When I try to run the demo listener and talker, I get the permission denied error. Using sudo does not help. The error comes after sourcing the ROS2 setup file and running ros2 run demo_nodes_cpp talker. All users do have execution permissions on the ros2 unix executable file being referenced.

edit retag flag offensive close merge delete



This isn't enough detail to help you. Please show the code you use and how you are calling it.

chfritz gravatar image chfritz  ( 2021-02-26 15:19:32 -0500 )edit

Same problem. macOS 11.2.2 after installing ROS2 Foxy. SIP has been disabled. donald@MacBook-Pro ~ % ros2 run demo_nodes_cpp talker zsh: permission denied: ros2 Removed com.apple.quarantine attribute: xattr -dr com.apple.quarantine ros2_foxy Still get the same error.

dhutchens gravatar image dhutchens  ( 2021-02-28 09:21:51 -0500 )edit

I added the command that caused the error

kaybug gravatar image kaybug  ( 2021-02-28 11:06:38 -0500 )edit

what do you get when you type which ros2 and ls -la $(which ros2)

chfritz gravatar image chfritz  ( 2021-02-28 11:50:33 -0500 )edit

which ros2 gives me /Users/kaycee/ros2_eloquent/ros2-osx/bin/ros2ls -la $(which ros2) gives me -rwxrwxrwx@ 1 kaycee staff 958 Feb 28 12:00

kaybug gravatar image kaybug  ( 2021-02-28 12:05:57 -0500 )edit

thanks. Do you get the same error when you just run ros2 (without any arguments)?

chfritz gravatar image chfritz  ( 2021-02-28 12:11:34 -0500 )edit

Yes, it's the same error

kaybug gravatar image kaybug  ( 2021-02-28 12:15:17 -0500 )edit