Ask Your Question
0

Ros2 Foxy fails installing in Ubuntu 20.10 arm64 following the official documentation

asked 2021-02-19 01:48:41 -0500

I'm trying for the last 3 days to install Ros2 Foxy (ros2-foxy-20201211-linux-focal-arm64.tar.bz2) in a freshly installed Ubuntu 20.10 arm64 running in a Raspberry Pi 4. Following the official documentation: https://index.ros.org/doc/ros2/Instal... I'm hitting several issues (in order following the official documentation steps):

1. Missing Groovy release

$> sudo sh -c 'echo "deb [arch=$(dpkg --print-architecture)] http://packages.ros.org/ros2/ubuntu $(lsb_release -cs) main" > /etc/apt/sources.list.d/ros2-latest.list'

$> sudo apt update

Err:5 http://packages.ros.org/ros2/ubuntu groovy Release 404 Not Found [IP: 64.50.233.100 80]

I can fix this issue changing groovy to focal in /etc/apt/sources.list.d/ros2-latest.list

2. Missing Ros dependencies

$> rosdep install --from-paths ros2-linux/share --ignore-src --rosdistro foxy -y --skip-keys "console_bridge fastcdr fastrtps osrf_testing_tools_cpp poco_vendor rmw_connext_cpp rosidl_typesupport_connext_c rosidl_typesupport_connext_cpp rti-connext-dds-5.3.1 tinyxml_vendor tinyxml2_vendor urdfdom urdfdom_headers"

ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies: launch: No definition of [python3-lark-parser] for OS version [groovy] rosidl_parser: No definition of [python3-lark-parser] for OS version [groovy] ros2doctor: No definition of [python3-ifcfg] for OS version [groovy] rmw_cyclonedds_cpp: No definition of [cyclonedds] for OS version [groovy]

Again I can solve this forcing os in rosdep with --os ubuntu:focal

2. Missing libraries

$> ros2 run demo_nodes_cpp talker

terminate called after throwing an instance of 'rclcpp::exceptions::RCLError' what(): failed to initialize rcl init options: failed to load shared library of rmw implementation: /home/ubuntu/ros2_foxy/ros2-linux/lib/librmw_fastrtps_cpp.so Exception: LoadLibrary error: libtinyxml2.so.6: cannot open shared object file: No such file or directory, at /home/jenkins-agent/workspace/ci_packaging_linux-aarch64/ws/src/ros2/rcutils/src/shared_library.c:84, at /home/jenkins-agent/workspace/ci_packaging_linux-aarch64/ws/src/ros2/rmw_implementation/rmw_implementation/src/functions.cpp:62, at /home/jenkins-agent/workspace/ci_packaging_linux-aarch64/ws/src/ros2/rcl/rcl/src/rcl/init_options.c:61


I tried as well the debian package installation instructions without success: https://index.ros.org/doc/ros2/Instal...

I need some help to find a solution for a working installation.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2021-02-19 03:59:49 -0500

gvdhoorn gravatar image

updated 2021-02-19 04:13:44 -0500

Perhaps already known, but officially, Foxy only supports Ubuntu Focal (20.04): REP 2000: ROS 2 Releases and Target Platforms - Foxy Fitzroy (May 2020 - May 2023).

The official documentation you link is fairly clear about this:

We support Ubuntu Linux Focal Fossa (20.04) 64-bit x86 and 64-bit ARM.

From the System Requirements section.

Missing Groovy release [..] I can fix this issue changing groovy to focal in /etc/apt/sources.list.d/ros2-latest.list

this isn't really a "fix": that would make apt install binaries compiled against Ubuntu Focal on Ubuntu Groovy.

There's a good chance this is the cause of your problems.

If it works, there's no guarantee it's going to be stable, as mixing-and-matching libraries of different versions is a good way to make an instable system.

edit flag offensive delete link more

Comments

that cause me a lot of crashes and problems

mam gravatar image mam  ( 2021-04-18 07:54:20 -0500 )edit

What caused crashes?

gvdhoorn gravatar image gvdhoorn  ( 2021-04-18 11:17:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-02-19 01:48:41 -0500

Seen: 775 times

Last updated: Feb 19