Problem doing catkin_make with fresh install on windows 10

asked 2021-02-04 07:14:15 -0600

azad gravatar image

updated 2021-02-05 00:53:05 -0600

Update: Doing cmake in catkin/src directory works fine but catkin_make still generates the following error.

After a fresh install on windows 10, catkin_make generates cmake errors requiring ninja and cmake paths are not set. I am running Catkin_make within visual studio command prompt however, i still get the following errors.


Running command: "cmake G:\ros_ws\src -DCMAKE_BUILD_TYPE=RelWithDebInfo -DCATKIN_DEVEL_PREFIX=G:\ros_ws\devel -DCMAKE_INSTALL_PREFIX=G:\ros_ws\install -G Ninja" in "G:\ros_ws\build"


CMake Error: CMake was unable to find a build program corresponding to "Ninja". CMAKE_MAKE_PROGRAM is not set. You probably need to select a different build tool. CMake Error: CMAKE_C_COMPILER not set, after EnableLanguage CMake Error: CMAKE_CXX_COMPILER not set, after EnableLanguage -- Configuring incomplete, errors occurred! See also "G:/ros_ws/build/CMakeFiles/CMakeOutput.log". Invoking "cmake" failed

edit retag flag offensive close merge delete



@azad, did you run the catkin_make from the command windows shortcut described in step 6 here? And make sure you have the Desktop development with C++ workload in your Visual Studio 2019.

Sean Yen gravatar image Sean Yen  ( 2021-02-04 13:28:18 -0600 )edit

Yes, I have tried both the "Visual Studio 2017 Developer Command Prompt v15.5.6" and the new "Windows Terminal". And ofcourse I have used the shortcut that launches the ros and have updated the settings of the windows terminal to load the ros. roscore works fine in both terminals but catkin_make gives cmake errors.

azad gravatar image azad  ( 2021-02-04 19:36:38 -0600 )edit

"And make sure you have the Desktop development with C++ workload in your Visual Studio 2019." Thanks Sean, that was my issue!

Open Visual Studio Installer and make sure you have the "Desktop development with C++" workload installed/downloaded.

kurtg76 gravatar image kurtg76  ( 2021-05-03 11:03:48 -0600 )edit