Ask Your Question
0

[Turtlebot3 Waffle Pi] Disconnects from the Internet

asked 2021-01-30 15:57:39 -0600

batini gravatar image

I am using ROS1 Kinetic with my Ubuntu 16.04. I also have Turtlebot 3 Waffle Pi. The setup was completed.


Here is the scenario I encounter,

First I start the roscore by

roscore

Then, I connect to my robot by SSH using the IP address. Then, I start the connection between my computer and the robot using

roslaunch turtlebot3_bringup turtlebot3_robot.launch

On my computer, I launch SLAM package by

roslaunch turtlebot3_slam turtlebot3_slam.launch

then, I launch the teleoperation package by

roslaunch turtlebot3_teleop turtlebot3_teleop_key.launch

I start to control my robot on the floor using the keyboard, and everything looks fine, but the robot doesn't sometimes stop when I press "s" to force stop. It proceeds its movement for 2-3 seconds. Then, it stops. Also, the SLAM values stop to publish on the terminal. This problem also occurs when I use navigation packages. The robot misses the goal position and keeps moving which is out of the plan. After sometime, it replans the path to reach the goal again. My guess is the robot disconnects from the Internet. Then, it reconnects. How can I solve this issue?

edit retag flag offensive close merge delete

Comments

Can you try connect another wifi for example share your phone internet and connect with your pc and turtlebot sbc in that wifi.

bekirbostanci gravatar image bekirbostanci  ( 2021-02-02 13:40:42 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-02-07 13:07:11 -0600

batini gravatar image

Hello guys, after I tried lots of things, I solved the problem. Two important things I did

  1. I disabled Raspberry Pi's Power Management following this tutorial: https://thepihut.com/blogs/raspberry-...
  2. I think the main problem is time synchronization with my PC (master) and my robot (turtlebot). Simply this issue helps https://answers.ros.org/question/2966...
edit flag offensive delete link more

Comments

i have tried 1. but it didnt change anything. the power management is still on :( 2. can you explain the set of commands for PC and turtlebot3?

syed yunas gravatar image syed yunas  ( 2021-03-20 19:14:57 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-01-30 15:54:43 -0600

Seen: 149 times

Last updated: Feb 07