Ask Your Question
0

problem with rosmaking mrpt_common package

asked 2012-06-22 02:24:27 -0500

bcddivad gravatar image

I'm using Ubuntu 10.04 and installed ros-electric I downloaded the mrpt_common package with folloeing script

  svn co http://mrpt-ros-pkg.googlecode.com/svn/trunk/mrpt_common

and rosmake it.

However, error occurred.

  bcddivad@bcddivad-desktop:~/code/ros/MRPT/mrpt_common$ rosmake
  [ rosmake ] No package or stack specified.  And current directory 'mrpt_common' is not a package name or stack name.                                                                                           
  [ rosmake ] Packages requested are: []                                                                                                                                                                         
  [ rosmake ] Logging to directory/home/bcddivad/.ros/rosmake/rosmake_output-20120622-201855                                                                                                                     
  [ rosmake ] Expanded args [] to:
  []                                                                                                                                                                            
  [ rosmake ] ERROR: No arguments could be parsed into valid package or stack names.                                                                                                                             
  bcddivad@bcddivad-desktop:~/code/ros/MRPT/mrpt_common$

I have the following line in my ~/.bashrc

  export ROS_PACKAGE_PATH=/home/bcddivad/code/ros;
  source /opt/ros/electric/setup.bash
  export ROS_PACKAGE_PATH=/home/bcddivad/code/ros/turtle_tf:/opt/ros/electric/stacks;

How can I solve this?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-06-22 02:43:49 -0500

Lorenz gravatar image

Your ROS_PACKAGE_PATH is wrong and the lines in your .bashrc look pretty messy. First you set the ROS_PACKAGE_PATH to the directory /home/bcddivad/code/ros, then you overwrite it and it is probably set to /opt/ros/electric/stacks and then you overwrite it again by setting it to /home/bcddivad/code/ros/turtle_tf:/opt/ros/electric/stacks which removes /home/bcddivad/code/ros.

In general, this kind of problems can easily be avoided by using something like rosws. Also have a look at this answer for a quick way to get things set up cleanly using rosws.

A quick fix in your case would be to edit ~/.bashrc and replace the three lines you posted by:

source /opt/ros/electric/setup.bash
export ROS_PACKAGE_PATH=$HOME/code/ros:$ROS_PACKAGE_PATH

That way, you use everything set up in /opt/ros/electric/setup.bash and you add $HOME/code/ros and all its subdirectories. You can verify the current ROS_PACKAGE_PATH by executing echo $ROS_PACKAGE_PATH.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-06-22 02:24:27 -0500

Seen: 339 times

Last updated: Jun 22 '12