ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

rosbridge: command not found

asked 2021-01-27 13:38:30 -0500

wkuznik gravatar image

updated 2021-01-27 13:39:04 -0500

When I try to run https://github.com/lgsvl/lanefollowing example, I get an error after execute "docker-compose up drive" Error: "rosbridge: command not found" Is this a problem from ROS2 "dashing" or rather lgsvl docker?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2021-01-27 13:50:34 -0500

Almost definitely an issue with their docker image. It's a wild guess, but it seems quite plausible that this is related to their latest commit, and in particular this change.

edit flag offensive delete link more

Comments

Thanks. That's my guess too, I'll try to contact someone at LGSVL and when the problem is solved close this question.

wkuznik gravatar image wkuznik  ( 2021-01-27 13:57:37 -0500 )edit
1

Problem solved: build new docker with ros-dashing-desktop (there is noch version 0.7.3-1 for dashing)

wkuznik gravatar image wkuznik  ( 2021-01-29 10:19:12 -0500 )edit

I am having the same problem. Could you clarify how you built the new docker? I could not understand the comment in paranthesis.

Klaus Schmidt gravatar image Klaus Schmidt  ( 2021-01-30 02:19:50 -0500 )edit
0

answered 2021-02-01 11:41:14 -0500

wkuznik gravatar image

updated 2021-02-01 13:21:19 -0500

Edit docker-file (Line 162: lanefollowing/Dockerfile, delete specific version=0.7.3-1)

RUN apt-get update && apt-get install -y \
ros-${ROS2_DISTRO}-desktop \
&& rm -rf /var/lib/apt/lists/*

Remove original docker

docker image ls
docker image rm <ID from pulled docker lgsvl/lanefollowing>

Build your own docker

docker build -t lgsvl/lanefollowing:latest -f Dockerfile .
edit flag offensive delete link more

Comments

because of tensorflow you need 4-5 hours to build it :)

wkuznik gravatar image wkuznik  ( 2021-02-01 11:44:00 -0500 )edit

Additional info: the current lanefollowing example don't support the newest lgsvl simulator. We have to wait about 1 month.

wkuznik gravatar image wkuznik  ( 2021-02-02 04:58:18 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2021-01-27 13:38:30 -0500

Seen: 314 times

Last updated: Feb 01 '21