ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

ResourceNotFound: gazebo_ros Issue

asked 2021-01-10 21:07:41 -0500

p.ferdosali gravatar image

I'm using: Ubuntu 16.04.7 LTS along with Gazebo multi-robot simulator, version 7.16.1 to lunch the simple arm robot from I can initiate and build my project, but when I run the following command:

$ roslaunch simple_arm robot_spawn.launch

I get the following error which seems to be an issue with catkin not finding my gazebo:

    Traceback (most recent call last):
      File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 308, in main
      File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 268, in start
      File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 217, in _start_infrastructure
      File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 132, in _load_config
        roslaunch_strs=self.roslaunch_strs, verbose=self.verbose)
      File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 451, in load_config_default
        loader.load(f, config, verbose=verbose)
      File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 750, i

n load
    self._load_launch(launch, ros_config, is_core=core, filename=filename, argv=argv, verbose=verbose)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 722, in _load_launch
    self._recurse_load(ros_config, launch.childNodes, self.root_context, None, is_core, verbose)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 686, in _recurse_load
    val = self._include_tag(tag, context, ros_config, default_machine, is_core, verbose)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 95, in call
    return f(*args, **kwds)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 589, in _include_tag
    inc_filename = self.resolve_args(tag.attributes['file'].value, context)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 183, in resolve_args
    return substitution_args.resolve_args(args, context=context.resolve_dict, resolve_anon=self.resolve_anon)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 370, in resolve_args
    resolved = _resolve_args(resolved, context, resolve_anon, commands)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 383, in _resolve_args
    resolved = commands[command](resolved, a, args, context)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 151, in _find
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 197, in _find_executable
    full_path = _get_executable_path(rp.get_path(args[0]), path)
  File "/usr/lib/python2.7/dist-packages/rospkg/", line 207, in get_path
    raise ResourceNotFound(name, ros_paths=self._ros_paths)
ResourceNotFound: gazebo_ros
ROS path [0]=/opt/ros/kinetic/share/ros
ROS path [1]=/home/liam/workspace/catkin_ws/src
ROS path [2]=/opt/ros/kinetic/share

Is there anything I'm missing? I appreciate your time and help!

edit retag flag offensive close merge delete



Try installing gazebo_ros from source. Source the catkin workspace and try again.

skpro19 gravatar image skpro19  ( 2021-01-11 13:02:04 -0500 )edit

This solved my problem, thanks @skpro19

marko525 gravatar image marko525  ( 2022-04-03 18:04:33 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2021-11-17 08:22:24 -0500

Divelix gravatar image

I had the same issue, try this:

sudo apt install ros-kinetic-gazebo-ros
edit flag offensive delete link more

Question Tools

1 follower


Asked: 2021-01-10 21:07:41 -0500

Seen: 6,402 times

Last updated: Nov 17 '21