Ask Your Question
1

Sourcing Bash File Runs into Error

asked 2020-12-21 11:26:03 -0500

Joesan gravatar image

I have a ROS node that I wanted to try out. It is the very first tutorial and I have the ROS Noetic on my Ubuntu 20.04 machine. I implemented a simple talker and listener nodes, have a launch file that I will use to run them. But when I tried to do the following, I ran into some strange bash error:

joesan@joesan-InfinityBook-S-14-v5:~/Projects/Private/ros-projects/ros_ws$ source devel/setup.bash 
bash: cd: too many arguments
drwxrwxr-x joesan joesan  4 KB Mon Dec 21 18:18:02 2020  .
drwxrwxr-x joesan joesan  4 KB Wed Sep  2 07:02:01 2020  ..
.rw-rw-r-- joesan joesan 98 B  Wed Sep  2 07:03:00 2020  .catkin_workspace
drwxrwxr-x joesan joesan  4 KB Tue Dec 15 20:07:31 2020  .vscode
drwxrwxr-x joesan joesan  4 KB Mon Dec 21 18:18:05 2020  build
drwxrwxr-x joesan joesan  4 KB Mon Dec 21 18:19:41 2020  devel
drwxrwxr-x joesan joesan  4 KB Fri Dec 18 19:35:26 2020  src
joesan@joesan-InfinityBook-S-14-v5:~/Projects/Private/ros-projects/ros_ws$

I do not understand how this error is being thrown?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2020-12-21 13:08:34 -0500

vinny gravatar image

I have seen this once before. can you try removeing your build and devel folders and attempt to build again? From what I remember, that solved the issue

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2020-12-21 11:26:03 -0500

Seen: 86 times

Last updated: Dec 21 '20