Ask Your Question
0

teleop not functioning with erratic

asked 2012-06-19 03:21:23 -0500

Gen_Robotino gravatar image

Hello, I am currently working with erratic and was able to get the robot to spawn in Gazebo by launching the launch files provided from the ros website. http://www.ros.org/wiki/erratic_description

But, the package did not include teleop, which is required to move the robot. I downloaded the teleop, and ran

rosrun erratic_teleop erratic_teleop_key

The command runs, but I am not able to move the robot. I used rxgraph, and it seems that the teleop node is not affecting the robot because it is not connected to it.

How would you make it so that the teleop node affects the erratic robot?

Thank you

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-07-30 04:37:25 -0500

updated 2012-08-08 06:04:28 -0500

I just tried to post a response but I'm not sure it worked. Just something simple that I found was an issue sometimes, when you're running gazebo the impulse is to have that window be in the foreground and more than likely the window with mouse focus (meaning, basically, it was the last window you've clicked). The terminal running the teleop program needs to be the window with focus to catch any keyboard events.

Hope that helps.

update:

Also I just noticed that when I updated some packages, gazebo is brought up with time paused. This can cause the teleop to appear like it's not working. If you click on play on the upper left of the gazebo window, things should starting working.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-06-19 03:21:23 -0500

Seen: 332 times

Last updated: Aug 08 '12