GSCAM problems using UDPSRC

asked 2020-12-09 16:41:30 -0500

antwes gravatar image


I'm having some problem to get my UDP video stream to be decoded by gscam. I'm using Ubuntu 14.04.4 LTS, ROS Indigo and my gscam has been built manually using CMake flag “-DGSTREAMER_VERSION_1_x=On”.

Gstreamer video shown correct using:

gst-launch-1.0 udpsrc port=50201 ! queue ! tsdemux ! h264parse ! decodebin ! autovideosink sync=false

When I try to use gscam I do the following steps:

export GSCAM_CONFIG="udpsrc port=50201 ! tsdemux ! h264parse ! decodebin ! videoconvert “

rosrun gscam gscam

Which gives me:

[ INFO] [1607550275.742974744]: Using gstreamer config from env: "udpsrc port=50201 ! tsdemux ! h264parse ! decodebin "

[ INFO] [1607550275.747167735]: using default calibration URL

[ INFO] [1607550275.747222002]: camera calibration URL: file:///home/antwes/.ros/camera_info/camera.yaml

[ INFO] [1607550275.747358681]: Unable to open camera calibration file [/home/antwes/.ros/camera_info/camera.yaml]

[ WARN] [1607550275.747401424]: Camera calibration file /home/antwes/.ros/camera_info/camera.yaml not found.

[ INFO] [1607550275.747435716]: Loaded camera calibration from

[ WARN] [1607550275.748100046]: No camera frame_id set, using frame "/camera_frame".

[ INFO] [1607550275.770456730]: Time offset: 1607526892,275

[ INFO] [1607550275.856253045]: Publishing stream...

[ INFO] [1607550275.856457401]: Started stream.

Then "rostopic list" shows gscam distributes topics, but when trying to view image:

rosrun image_view image_view image:=/camera/image_raw

Nothing shows, just a grey window.

Anyone hsa ideas of what is going wrong here? Could it be that video has the wrong format, read it must be RGB in the gscam doc. I've tried different parameters to the "videconvert" tag to convert output but no success.

Please help! :)

edit retag flag offensive close merge delete


Are you getting images at the expected framerate? I notice that you dropped the queue element in GSCAM_CONFIG -- was that intentional?

It would be helpful to include a self-contained pipeline using videotestsrc, that makes it easier for others to reproduce the problem.

You could try to increase the GST_DEBUG level, perhaps: GST_DEBUG=4 gst-launch-1.0 ... There is a lot of debug output, but you'll often see interesting errors.

clyde gravatar image clyde  ( 2021-03-24 15:01:11 -0500 )edit

Another idea to try: sync_sink defaults to true in gscam, try setting it to false. This will match your gst-launch-1.0 test pipeline.

clyde gravatar image clyde  ( 2021-05-20 11:05:20 -0500 )edit