Ask Your Question
0

costmap_generator node do not work well! #2361

asked 2020-12-07 19:04:54 -0500

rosli gravatar image

Operating system and version: Ubuntu 18.04 !! Autoware installation type: From source Autoware version or commit hash version 1.11.0! ROS distribution and version: ROS installation type: gudide Package or library, if applicable: robosen-16 lidar!

costmap_generator node work ,it is costmap show in the rviz!but is message data[] all zero ! it lead to astar_search.cpp do not work well,because ,if the data==0 , it skip the function of ,void AstarSearch::initialize(const nav_msgs::OccupancyGrid& costmap) in the astar_search. and lead to the warn !!invalid start pose ! then ,the astar_navi cannot work well !!!

the /semantics/costmap_generator/occupancy_grid data should have data!

it have no data!! header: seq: 522 stamp: secs: 1607331011 nsecs: 713829000 frame_id: "velodyne" info: map_load_time: secs: 0 nsecs: 0 resolution: 0.20000000298 width: 150 height: 250 origin: position: x: -15.0 y: -5.0 z: 0.0 orientation: x: 0.0 y: 0.0 z: 0.0 w: 1.0 data: [0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0 ... (more)

edit retag flag offensive close merge delete

Comments

The same problem here. Did you figure out how to solve?

marcusvini178 gravatar image marcusvini178  ( 2021-05-03 08:31:54 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2021-08-31 22:32:27 -0500

marcusvini178 gravatar image

Here to send the solution for some users that faced the same issue.

The tutorials that I have followed and described above in my question are WRONG! If you launch the costmap_generator through the runtime manager or terminal, the occupancy grid map will not be generated or very very rarely....

To fix this there are 2 options:

1). Using Run-time Manager: on Computing Tab click over app option in costmap_generator, scroll down until you find the Lanelet2 checkbox option at the left bottom. CHECK this box ✔️

2) Inside the docker, using a new terminal launch: roslaunch costmap_generator costmap_generator_lanelet2.launch Ok now the costmap_generator will generate the occupancy_grid_map

3) Just Pay attention that you must check the ray_ground filter or compare_map_filter on Sensing Tab

However this will not help as the A* keeps not avoiding and crashing the Obstacle, as described in my issue: https://github.com/Autoware-AI/autowa...

If someone fix this A* please let me know

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-12-07 19:04:54 -0500

Seen: 86 times

Last updated: Aug 31