ROS_DOMAIN_ID with microROS

asked 2020-11-29 18:10:13 -0500

Francis Zaato gravatar image

Hi Everyone,

New to ROS but not to embedded systems.

I installed ROS2 Foxy on Ubuntu 20.04 in a virtualbox VM with a bridged network adapter.

Completed this tutorial successfully: https://micro-ros.github.io/docs/tuto...

Tried the next tutorial but modified for freertos on ESP32: https://micro-ros.github.io/docs/tuto...

Unable to complete succesfully until I realized that the ROS_DOMAIN_ID setting had an impact on the microROS setup.

I had originally set up my foxy with ROS_DOMAIN_ID = 7 and also foxy on a raspberry pi 4 with ROS_DOMAIN_ID = 7 and there was no trouble. However, the microROS on the esp32 would not report the /microROS/ping and /microROS/pong when ROS_DOMAIN_ID = 7. It reports correctly when ROS_DOMAIN_ID = 0.

Please see the attached pic for a graphical highlight of the situation.

I think this is a feature, but is documented or undocumented? :)

Looking forward to answers. Thanks.

Regards, F

PS: Just found out I don't have enough points to upload the image......you're gonna have to take my word for it. :) PS2: Here's the pic: https://imgur.com/a/CXn3ZUG

edit retag flag offensive close merge delete

Comments

Just found out I don't have enough points to upload the image

I've given you sufficient karma to post images, but: it appears your screenshot shows terminal text.

There is no need to post screenshots of text, as it's text. Just copy-paste it into your question, select it and press the Preformatted Text button (the one with 101010 on it) to format it properly.

gvdhoorn gravatar image gvdhoorn  ( 2020-11-30 02:03:07 -0500 )edit

Thanks for the karma and suggestion! :)

Francis Zaato gravatar image Francis Zaato  ( 2020-11-30 02:25:37 -0500 )edit