Error when installing ros-melodic-desktop-full [closed]

asked 2020-11-24 04:18:35 -0600

Audric Saragih gravatar image

updated 2020-11-24 10:07:33 -0600

Error

I'm trying to install the ros desktop full version on my pc (Ubuntu 20.04 LTS) following these steps. Everything is fine from step 1.1-1.3. This is some error i had :

  • Run apt update

Sometimes,

sudo apt update

give me an error like this :

W: Failed to fetch http://packages.ros.org/ros/ubuntu/di... Connection failed [IP: 64.50.236.52 80] W: Some index files failed to download. They have been ignored, or old ones used instead.

I'm trying to run apt update several times. It can be done without error in the third try, but that error message can appear again in the fourth time. I'm very confused. apt update and apt-get update give me same result.

  • Install desktop full

I'm trying install desktop full with :

sudo apt install ros-melodic-desktop-full

Note : I'm running these step when apt update and apt upgrade done without error

Error message :

The following packages have unmet dependencies: ros-melodic-desktop-full : Depends: ros-melodic-desktop but it is not going to be installed Depends: ros-melodic-perception but it is not going to be installed Depends: ros-melodic-simulators but it is not going to be installed Depends: ros-melodic-simulators but it is not going to be installed Depends: ros-melodic-urdf-sim-tutorial but it is not going to be installed E: Unable to correct problems, you have held broken packages.

What I've tried

  • Using aptitude

sudo aptitude install ros-melodic-desktop-full

I'm running that several times, but in the end give me constant error : very long, with 220 package not installed.

  • Read and try solution here and here.

  • Using synaptic and get this.

Edit

This is my /etc/apt/sources.list.d/ros-latest.list content :

deb http://packages.ros.org/ros/ubuntu focal main

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Audric Saragih
close date 2021-05-13 07:07:01.193536

Comments

Just to clarify: You say

I'm trying to install the ros desktop full version on my pc (Ubuntu 20.04 LTS)

but Melodic is NOT available for 20.04. To cite the Installation page:

ROS Melodic Morenia distribution, which is available for Ubuntu Artful (17.10), Bionic (18.04 LTS)

The fact that you are apparently fetching the packages for focal (see your first error message, which could be just a temporary internet connectivity issue, btw), but still have apt know about the melodic packages suggests that there is something seriously wrong with your configuration.

Please edit your question and add the contents of /etc/apt/sources.list.d/ros-latest.list (or any other file referencing ROS therein...)

mgruhler gravatar image mgruhler  ( 2020-11-24 09:17:57 -0600 )edit

I have edit my question. Yes, i guess so, that is because my internet connectivity issue since that is not my major issue in this case. Oh that's my fault. I don't know about that. But my friend install Melodic in Ubuntu 20.04 too, and he succeed. Then, when i install Noetic, it give me same error message (unmet dependencies). Just replace the 'melodic' to 'noetic'.

Audric Saragih gravatar image Audric Saragih  ( 2020-11-24 10:12:48 -0600 )edit

If this is the only reference, you shouldn't be able to find any ros-melodic-* packages on Ubuntu 20.04. While it is certainly possible to install Melodic in 20.04, this could only be done from source (or very bad hacks). There are simply no released packages into 20.04 for melodic.

Have you tried sudo apt install -f? Otherwise try to purge all of ROS and reinstall.

However, I still think your system is messed up if you are able to find ros-melodic-* packages on Ubuntu 20.04...

mgruhler gravatar image mgruhler  ( 2020-11-25 01:57:18 -0600 )edit