Ask Your Question
0

Trouble using mavros /rc/in topic with pixhawk

asked 2020-11-23 06:18:39 -0600

Ash_J gravatar image

updated 2020-11-24 23:37:05 -0600

I'm using a Herelink remote controller which is connected to pixhawk purple-cube via mavlink2 protocol on the telem-2 connector pin. I'm trying to read the rc/in topic in mavros (using rostopic echo). command used:

roslaunch mavros apm.launch fcu_url:=serial:///dev/ttyACM0:57600

This is what I can see:

{
header: 
  seq: 71
  stamp: 
    secs: 1606131722
    nsecs: 352759947
  frame_id: ''
rssi: 0
channels: []
}

As you can see, none of the 16 channels are visible. No changes in the rc/in channels array occur even with button/stick inputs from the herelink controller.

Do note that communication between the pixhawk and the computer is working well, I ran rostopic echo /mavros/imu/data and the appropriate data was being published and could be viewed.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-11-24 08:21:10 -0600

miura gravatar image

updated 2020-11-26 10:11:26 -0600

It is like the rc_io plugin to publish /rc/in.

http://wiki.ros.org/mavros#mavros.2FP...

However, by default, rc_io is not read.

https://github.com/mavlink/mavros/blo...

Maybe it works by adding rc_io to the list of `apm_pluginlits.yaml'.


old

The rostopic pub is a command to be used when you want to publish a topic. To read it, use the rostopic echo as you do in /mavros/imu/data.

It is recommended that you check the rostopic list to see if /rc/in is flowing.

edit flag offensive delete link more

Comments

Hey! Yes, I did run rostopic echo. It was a typo in the question, have corrected it.

Ash_J gravatar image Ash_J  ( 2020-11-24 23:38:45 -0600 )edit

also rostopic list does show /rc/in available

Ash_J gravatar image Ash_J  ( 2020-11-24 23:39:30 -0600 )edit

This may change if you run it after sudo chmod a+rw /dev/ttyACM0.

miura gravatar image miura  ( 2020-11-25 10:01:45 -0600 )edit

Hi, tried this, no change, got the same result with no channels visible, just an empty array.

Ash_J gravatar image Ash_J  ( 2020-11-26 01:22:50 -0600 )edit

Surveyed and updated responses.

miura gravatar image miura  ( 2020-11-26 10:12:11 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2020-11-23 06:18:39 -0600

Seen: 306 times

Last updated: Nov 26 '20