ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

Ubuntu 18.04 RVIZ installation

asked 2020-11-23 02:10:32 -0600

Tricia279 gravatar image

updated 2020-11-24 16:41:11 -0600

jayess gravatar image

I try to install ROS for a YDLIDAR X2. At the step: RVIZ installation some package are not founded (in this row):

  1. python-serial
  2. melodic-serial
  3. ros-melodic-turtlebot3-rviz-lauchners

Did anyone has expierences in this matter ? I real appreciate your help...

edit retag flag offensive close merge delete

Comments

Please, post the commands you used and the error message.

tryan gravatar image tryan  ( 2020-11-23 09:30:48 -0600 )edit

robert@robert-desktop:~$ sudo apt-get install ros-melodic-turtlebot-rviz-launchers [sudo] password for robert: Paketlisten werden gelesen... Fertig Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig E: Paket ros-melodic-turtlebot-rviz-launchers kann nicht gefunden werden.

Sorry it is in German, but use DeepL for translation.

I tried this so many times, I can't know. Where to start...

Do you need a special logfile for more infos ?

Tricia279 gravatar image Tricia279  ( 2020-11-24 02:52:21 -0600 )edit

I find very impolite to throw here the issue in german and just say "use a traductor". if you ask for help, waste a little more time properly adding the issue.

I don't understand why you use this command to install RVIZ, when i did not saw any tutorial using it (and actually this is not rviz raw) it seems like a very old package which maybe is deprecated in melodic. if you want to install rviz, just try:

sudo apt-get install ros-melodic-rviz

If you are using this specific command for something, give us the tutorial you are trying to use.

Solrac3589 gravatar image Solrac3589  ( 2020-11-24 07:23:17 -0600 )edit

If it would be so easy to use your suggesstion, I would NOT have posted it here. I really tried everything and my investigation come to the result that only:

sudo apt-get install ros-indigo-turtlebot-rviz

may be is possible, but I didn't tested it right now.

Tricia279 gravatar image Tricia279  ( 2020-11-26 02:49:21 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2020-11-24 09:45:35 -0600

tryan gravatar image

I assume you're following this YDLiDAR manual or similar, but the turtlebot-rviz-launchers package is indeed outdated (its GitHub repo was last updated 6 years ago). The YDLiDAR GitHub documentation is a more up-to-date resource.

As a side note, RViz is installed with the desktop ROS installations, so you may already have it. If you don't have RViz from the ROS install and need it, Solrac3589's command is correct:

sudo apt-get install ros-melodic-rviz
edit flag offensive delete link more

Comments

Thank you for GitHub informations, but ofcourse had it allready. Step5 and step6 is interesting for reviewing my installation. The main problem is still what I wrote before to Solrac3589. If it works, I keep you informed.

Tricia279 gravatar image Tricia279  ( 2020-11-26 03:11:31 -0600 )edit

If there is a problem with the instructions on YDLidar's GitHub, I strongly recommend troubleshooting that rather than the out-dated package installation, but the choice is obviously yours to make. Installing a package from a different ROS version may work if it's not too complex. Good luck!

tryan gravatar image tryan  ( 2020-11-26 07:51:06 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2020-11-23 02:10:32 -0600

Seen: 3,021 times

Last updated: Nov 24 '20