Cannot automatically source script in every bash terminal

asked 2020-11-20 01:25:01 -0600

Hello. As per instructions on the noetic setup tutorial I cannot get the zsh sector to work under 1.5 Environment Setup. After inputting the command : echo "source /opt/ros/noetic/setup.zsh" >> ~/.zshrc I proceed to input the command : source ~/.zshrc This returns the following result, and I cannot understand what is wrong. I am very new to ROS and programming so my apologies if this is a stupid question. Result returned : bash: cd: -q: invalid option cd: usage: cd [-L|[-P [-e]] [-@]] [dir] emulate: command not found bash: cd: -q: invalid option cd: usage: cd [-L|[-P [-e]] [-@]] [dir] emulate: command not found bash: cd: -q: invalid option cd: usage: cd [-L|[-P [-e]] [-@]] [dir] emulate: command not found

I am using the latest version of noetic and have just upgraded all the packages. I am also using ROS on a virtual machine of ubuntu 20.04 Am I missing a package that does not contain the emulate command? I am quite sure I enabled the three main repositories required and installed all the updates. I did install the full desktop version of noetic. Thank you for any help.

edit retag flag offensive close merge delete