Ask Your Question
0

How to make hector_planner works in ROS Melodic

asked 2020-11-19 03:07:39 -0600

Chronz gravatar image

updated 2020-11-19 23:05:49 -0600

Edited

I can't seem to get it right running in the machine that i'm using. Currently i'm using Ubuntu Mate 18.04 as i will implement it in Raspberry Pi, but before that i'm testing it in the computer right now.

The error i'm getting is below

-- +++ processing catkin package: 'hector_gps_calibration' -- ==> add_subdirectory(hector_navigation/hector_gps_calibration) -- Using these message generators: gencpp;geneus;genlisp;gennodejs;genpy CMake Error at /home/foriansyah/catkin_ws/devel/share/ceres_catkin/cmake/ceres_catkinConfig.cmake:173 (message): Project 'hector_gps_calibration' tried to find library 'ceres'. The library is neither a target nor built/installed properly. Did you compile project 'ceres_catkin'? Did you find_package() it before the subdirectory containing its code is included? Call Stack (most recent call first): /opt/ros/melodic/share/catkin/cmake/catkinConfig.cmake:76 (find_package) hector_navigation/hector_gps_calibration/CMakeLists.txt:10 (find_package)

-- Configuring incomplete, errors occurred! See also "/home/foriansyah/catkin_ws/build/CMakeFiles/CMakeOutput.log". See also "/home/foriansyah/catkin_ws/build/CMakeFiles/CMakeError.log". Makefile:4632: recipe for target 'cmake_check_build_system' failed make: * [cmake_check_build_system] Error 1 Invoking "make cmake_check_build_system" failed

I have tried to do what https://answers.ros.org/question/2977... has and it still is not working after installing both the catkin_ceres and simple_catkin

Is there any way to make it work? Thanks in advance

edit retag flag offensive close merge delete

Comments

I tried https://answers.ros.org/question/3648... this as well, and the error im getting is now at the above

Chronz gravatar image Chronz  ( 2020-11-19 23:09:33 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-11-19 18:47:02 -0600

Alex Beh CJ gravatar image

Try git clone navigation , checkout the melodic-devel and catkin_make again.

edit flag offensive delete link more

Comments

I tried to add the dependencies, and cloning it as well, but it still won't work thanks for the response tho~

Chronz gravatar image Chronz  ( 2020-11-19 21:45:47 -0600 )edit

uh Alex, i tried to add the navigation pkg in the src. What does it used for?

Chronz gravatar image Chronz  ( 2020-11-19 23:42:28 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-11-19 01:12:08 -0600

Seen: 22 times

Last updated: Nov 19