Ask Your Question
1

Rostopic delay 50 years

asked 2020-11-15 05:51:37 -0500

Dejv311 gravatar image

Hello,

I am trying to read my camera, but I am facing huge delays when viewing the image (up to minutes). This delay is right from the start of the program and doesnt seem to improve when launched for longer time (maybe it gets worse). Furthermore when i try rostopic delay, I get this:

rostopic delay /tello/camera/image_raw
subscribed to [/tello/camera/image_raw]
average delay: 1605442030.094
    min: 1605442029.685s max: 1605442030.537s std dev: 0.25970s window: 23
average delay: 1605442030.611
    min: 1605442029.685s max: 1605442031.547s std dev: 0.55886s window: 48
average delay: 1605442031.101
    min: 1605442029.685s max: 1605442032.544s std dev: 0.83966s window: 72
average delay: 1605442031.597
    min: 1605442029.685s max: 1605442033.533s std dev: 1.12961s window: 96

On the subscriber side I ran both

rosrun image_view image_view image:=/tello/camera/image_raw _autosize:=true

and aruco_detect [link], both seem to have the same ammount of delay (when I place aruco infront of the camera I see it both visually via image_view and in console via aruco_detect at the same time). The publisher of camera/image_raw and camera/camera_info is the original ROS Tello library [link], the publisher being here [link]. As you can see from the code, the queue size is set to 10 (could be lowered to one for my use case), but I guess that does not solve my 50 years problem (which I guess has smth to do with 1970 computer time).

My guess is, that the camera info sent by drone has computer time since the start of drone (here the 50y delay), but I have no idea how to fix that or even if that solves my camera lag issue as the frames seen on screen should not exist no more due to the queue limit. I would highly appreciate help of someone more experienced than I am. Thank you

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2020-11-15 07:56:53 -0500

I think the /use_sim_time parameter should be true. The rosparam set /use_sim_time false may solve this problem.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2020-11-15 05:51:37 -0500

Seen: 185 times

Last updated: Nov 15 '20