Ask Your Question
0

Recommendation regarding Jetson TX2 production usage of ROS2

asked 2020-11-15 02:06:49 -0600

Dronist gravatar image

updated 2020-11-15 02:07:13 -0600

Hi, We are a number of developers who are developing in ROS and we are about to move to ROS2, now we are debating about the configuration we will work with - Foxy or Eloquent: Our dilemmas are as follows

  1. We are working on Jetson TX2 - according to NVIDIA there is no official version of Ubuntu 20.04 that is expected to be released soon - which means we can only use Ubuntu 18.04 -> only eloquent(or foxy on docker).

  2. We are interested in working with the newest and most stable version available.

  3. We are working with Intel realsense which has not yet released an official version that supports Foxy.

  4. We tried to work with foxy in Docker but it seems that for long term development it is not suitable because working with visualization is very complicated and also the work for a number of developers and a large number of ROS nodes is also not suitable for this.

I would love to get a recommendation on what in your opinion would be the best decision for us in this case.

  • We know that eloquent is EOL, but don't really understand what could be the long-term consequences?
edit retag flag offensive close merge delete

Comments

We know that eloquent is EOL, but don't really understand what could be the long-term consequences?

Similar to other software/products which go end-of-life:

  • no new features
  • no security patches
  • no bug fixes
  • no support (other than community fora)
  • no updates to packages
  • no new packages
  • no new docker images
  • no releases for new OS

etc, etc.

gvdhoorn gravatar image gvdhoorn  ( 2020-11-15 02:27:06 -0600 )edit

Thanks @gvdhoorn, So what is your recommendation given the constraints I have presented?

Dronist gravatar image Dronist  ( 2020-11-15 02:30:19 -0600 )edit

Nothing (yet), as I don't know what this means:

We tried to work with foxy in Docker but it seems that for long term development it is not suitable because working with visualization is very complicated and also the work for a number of developers and a large number of ROS nodes is also not suitable for this.

What does "is not suitable for this" mean?

And anecdotal, but UI applications can be used with Docker, it's just slightly more involved.

gvdhoorn gravatar image gvdhoorn  ( 2020-11-15 03:42:39 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-12-29 16:19:13 -0600

Kajack gravatar image

Eloquent using Debian pkg install is the easy choice now compared to Foxy and manual build/install. I had missing Debian packages for Foxy install Jetson / Ubuntu 18, and repo signature problems expecting Ubuntu 20.04. Some Foxy code referenced example_interfaces, but it was easy to write those for Eloquent. Foxy will be a good choice in a few months when Canocal releases Ubuntu 20 for Jetson.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

4 followers

Stats

Asked: 2020-11-15 02:06:49 -0600

Seen: 377 times

Last updated: Nov 15 '20