ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

Compiling Noetic on armhf buster

asked 2020-11-11 06:20:26 -0600

Matej101 gravatar image

Hello, I'm trying to install ROS Noetic-robot on a Pi zero w. Since there is no precompiled binary for armhf, I tried compiling it myself.

compiling always fails on the catkin package, saying it can't see empy. I do have python3-empy installed.

-- Could NOT find PY_em (missing: PY_EM) CMake Error at cmake/empy.cmake:30 (message): Unable to find either executable 'empy' or Python module 'em'... try installing the package 'python3-empy' Call Stack (most recent call first): cmake/all.cmake:164 (include) CMakeLists.txt:8 (include)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2020-11-11 07:22:19 -0600

Matej101 gravatar image

updated 2020-11-11 17:57:01 -0600

UPDATE: using -DPYTHON_EXECUTABLE=/usr/bin/python3 as a catkin_make_isolated argument appears to fix the problem. I also increased SWAP to 2GiB, so that might be needed too.

edit flag offensive delete link more

Comments

Ankther Update: The compilation took about 10 hours but it was successful. I tried several packages and they were working properly.

Might be worthwile to add instalation instryctions for Noetic on a Pi, since previos distros have them.

Matej101 gravatar image Matej101  ( 2020-11-11 17:57:05 -0600 )edit

I'm doing this myself at the minute and writing up my notes as I go, I'll update the wiki accordingly :)

kneave gravatar image kneave  ( 2021-01-17 15:44:16 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2020-11-11 02:59:52 -0600

Seen: 335 times

Last updated: Nov 11 '20