How can I get roscpp_internal's debug logging to respect log levels? [closed]

asked 2012-06-14 07:17:49 -0600

updated 2012-06-18 04:31:26 -0600

I've noticed roscpp_internal seems to ignore rosconsole.config, on top of which it seems to spit a large amount of DEBUG messages about tcp ports being brought up and torn down with each service call.

This is causing a log size issue.

Anyone know how to get roscpp_internal DEBUG to shut up without requiring building ros from source?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-03-09 20:29:40.489779

Comments

1

Are you seeing debug logs without having them enabled? I only know the rxloggerlevel/rxconsole tools and the log4..-configuration.

felix k gravatar image felix k  ( 2012-07-17 02:42:32 -0600 )edit