Ask Your Question
1

Problems whie compiling turtlebot packages

asked 2012-06-14 04:01:39 -0600

apalomer gravatar image

Hi, I'm compiling some turtlebot packages and I get this error while compiling turtlebot_self_filter:

  mkdir -p bin
  cd build && cmake -Wdev -DCMAKE_TOOLCHAIN_FILE=`rospack find rosbuild`/rostoolchain.cmake  ..
  [rosbuild] Building package turtlebot_self_filter
  [rosbuild] Including /opt/ros/electric/stacks/ros_comm/clients/roslisp/cmake/roslisp.cmake
  [rosbuild] Including /opt/ros/electric/stacks/ros_comm/clients/rospy/cmake/rospy.cmake
  [rosbuild] Including /opt/ros/electric/stacks/ros_comm/clients/cpp/roscpp/cmake/roscpp.cmake
  -- Configuring done
  -- Generating done
  -- Build files have been written to: /home/turtlebot/ros_electric/turtlebot_apps/turtlebot_self_filter/build
  cd build && make -l4
  make[1]: Entering directory `/home/turtlebot/ros_electric/turtlebot_apps/turtlebot_self_filter/build'
  make[2]: Entering directory `/home/turtlebot/ros_electric/turtlebot_apps/turtlebot_self_filter/build'
  make[3]: Entering directory `/home/turtlebot/ros_electric/turtlebot_apps/turtlebot_self_filter/build'
  make[3]: Leaving directory `/home/turtlebot/ros_electric/turtlebot_apps/turtlebot_self_filter/build'
  [  0%] Built target rospack_genmsg_libexe
  make[3]: Entering directory `/home/turtlebot/ros_electric/turtlebot_apps/turtlebot_self_filter/build'
  make[3]: Leaving directory `/home/turtlebot/ros_electric/turtlebot_apps/turtlebot_self_filter/build'
  [  0%] Built target rosbuild_precompile
  make[3]: Entering directory `/home/turtlebot/ros_electric/turtlebot_apps/turtlebot_self_filter/build'
  make[3]: Leaving directory `/home/turtlebot/ros_electric/turtlebot_apps/turtlebot_self_filter/build'
  make[3]: Entering directory `/home/turtlebot/ros_electric/turtlebot_apps/turtlebot_self_filter/build'
  Linking CXX executable ../bin/laser_footprint_filter
  /opt/ros/electric/stacks/perception_pcl/pcl/lib/libpcl_visualization.so: undefined reference to `__cxa_pure_virtual@libmysqlclient_16'
  collect2: ld returned 1 exit status
  make[3]: *** [../bin/laser_footprint_filter] Error 1
  make[3]: Leaving directory `/home/turtlebot/ros_electric/turtlebot_apps/turtlebot_self_filter/build'
  make[2]: *** [CMakeFiles/laser_footprint_filter.dir/all] Error 2
  make[2]: Leaving directory `/home/turtlebot/ros_electric/turtlebot_apps/turtlebot_self_filter/build'
  make[1]: *** [all] Error 2
  make[1]: Leaving directory `/home/turtlebot/ros_electric/turtlebot_apps/turtlebot_self_filter/build'

I algo get a similar error while trying to execute turtlebot_bringup kinect.launch:

[ERROR] [1339682184.543002698]: Failed to load nodelet [/pointcloud_throttle] of type [pointcloud_to_laserscan/CloudThrottle]: Failed to load library /home/turtlebot/ros_electric/turtlebot/pointcloud_to_laserscan/lib/libcloud_to_scan.so. Make sure that you are calling the PLUGINLIB_REGISTER_CLASS macro in the library code, and that names are consistent between this macro and your XML. Error string: Cannot load library: /opt/ros/electric/stacks/perception_pcl/pcl/lib/libpcl_visualization.so.1.1: symbol __cxa_pure_virtual, version libmysqlclient_16 not defined in file libmysqlclient.so.16 with link time reference
[FATAL] [1339682184.558845604]: Service call failed!

It looks like both things lead to the same: __cxa_pure_virtual@libmysqlclient_16

Some hint on that?

chers!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2012-06-14 15:07:38 -0600

Ryan gravatar image

updated 2012-10-11 11:03:54 -0600

Try:

sudo apt-get install libmysqlclient16

If using ubuntu/debian, make sure to check that the update repositories are enabled by checking that /etc/apt/sources.list has:

deb http://archive.ubuntu.com/ubuntu lucid-updates universe main multiverse

Or by checking in Synaptic in settings>repositores>updates>recommended updates checkbox.

edit flag offensive delete link more

Comments

it worked. Thanks!

apalomer gravatar imageapalomer ( 2012-06-15 03:36:29 -0600 )edit

Worked for me too in a different context. Thanks!

David Lu gravatar imageDavid Lu ( 2012-06-21 06:10:38 -0600 )edit

What version of libmysqlclient16 do you have? I've it installed, but still am receiving the dreaded undefined "__cxa_pure_virtual@libmysqlclient_16".

Asomerville gravatar imageAsomerville ( 2012-10-11 10:43:26 -0600 )edit

it worked. Thanks!

sven_007 gravatar imagesven_007 ( 2012-10-30 16:58:22 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-06-14 04:01:39 -0600

Seen: 1,021 times

Last updated: Oct 11 '12