Controller Spawner couldn't find the expected controller_manager ROS interface.

asked 2020-10-29 18:26:56 -0500

PGTKing gravatar image

Hi, After putting in the terminal (roslaunch rrbot_control rrbot_control.launch) it is telling me the the controller spawner couldn't find the expected controller_manager ROS interface. I am trying to send a position command to a joint on my robot through the terminal.

Thanks

edit retag flag offensive close merge delete

Comments

@pregnantghettoteen Maybe naive, but have you installed in your machine the controllers packages you are using?

Weasfas gravatar image Weasfas  ( 2020-10-30 05:19:06 -0500 )edit

@Weasfas yes I have done sudo apt-get install ros-noetic-joint-state-controller in the terminal as well as sudo apt-get install ros-noetic-position-controllers and sudo apt-get install ros-noetic-effort-controllers but to no avail. I read in another forum to killall gservers but not sure how to do that.

PGTKing gravatar image PGTKing  ( 2020-10-30 13:14:31 -0500 )edit

@pregnantghettoteen, when you launch Gazebo with GUI enabled it can happen that the gzserver is not properly killed. You can kill any process in your machine with kill PID -9 being the PID a number that you can find with the command ps -aux | grep gz. If that is not the case, when the controllers are not able to load is because too much time has passed since the start or the interface you are loading is not compatible with the controllers you are using. One more reason is that the ROS controller manager is unable to find properly the controllers becuase they are not loaded in the proper namespace. Besides, the package you are using refers to a tutorial, have you change anything of that package?

Weasfas gravatar image Weasfas  ( 2020-10-31 07:26:06 -0500 )edit

fixed, I did not have the gazebo simulator running

PGTKing gravatar image PGTKing  ( 2020-11-03 16:41:12 -0500 )edit