MoveIt crash : undefined symbol in libmoveit_kdl_kinematics_plugin.so

asked 2020-10-23 03:09:40 -0500

dondel gravatar image

Hi, I am having a recurrent crash of moveIt when calling plan = move_group.go(wait=True) in the Python Move Group Python Interface Tutorial code.

The error I get is :

/opt/ros/melodic/lib/moveit_ros_move_group/move_group: symbol lookup error: /opt/ros/melodic/lib//libmoveit_kdl_kinematics_plugin.so: undefined symbol: _ZNK3KDL6Vector4NormEv
[move_group-1] process has died [pid 16296, exit code 127, cmd /opt/ros/melodic/lib/moveit_ros_move_group/move_group __name:=move_group __log:=LOG_FILE].
log file: LOG_FILE

The log file does not exist.

The warnings I get from this node prior to that are :

[ WARN] [1603439117.230713337]: Skipping virtual joint 'virtual_joint' because its child frame 'panda_link0' does not match the URDF frame 'world'

and :

[ERROR] [1603439189.763401191, 98.488000000]: Exception while loading planning adapter plugin 'default_planner_request_adapters/ResolveConstraintFrames': According to the loaded plugin descriptions the class default_planner_request_adapters/ResolveConstraintFrames with base class type planning_request_adapter::PlanningRequestAdapter does not exist. Declared types are  default_planner_request_adapters/AddIterativeSplineParameterization default_planner_request_adapters/AddTimeOptimalParameterization default_planner_request_adapters/AddTimeParameterization default_planner_request_adapters/Empty default_planner_request_adapters/FixStartStateBounds default_planner_request_adapters/FixStartStateCollision default_planner_request_adapters/FixStartStatePathConstraints default_planner_request_adapters/FixWorkspaceBounds

I'm running ROS Melodic and the binary install of MoveIt on Ubuntu 18.04.1 (kernel 5.4.0-52-generic)

Have someone ever got this error or does someone know how to solve it ?

Thanks in advance

edit retag flag offensive close merge delete

Comments

2

Not a very helpful comment, but it's a problem with your install. Did you try reinstalling from scratch or running it in a fresh Docker container?

fvd gravatar image fvd  ( 2020-10-23 08:48:10 -0500 )edit
1

There were people with the same issue, although they haven't solved it yet. https://answers.ros.org/question/3608...

miura gravatar image miura  ( 2020-10-24 00:36:09 -0500 )edit
1

I reinstalled everything and it solved my problem ! Thanks for the help

dondel gravatar image dondel  ( 2020-10-27 04:05:26 -0500 )edit