gazebo-gui-3 process has died

asked 2020-10-21 10:12:17 -0600

ARaff gravatar image

updated 2020-10-22 12:26:40 -0600

I'm using ROS noetic on Ubuntu 20, trying to run the command "roslaunch package spawn.launch" after doing "source /opt/ros/noetic/setup.bash" and "source devel/setup.bash". I get the following:

"[INFO] [1603291907.439879200]: waitForService: Service [/gazebo_gui/set_physics_properties] has not been advertised, waiting..

Aborted (core dumped)

[gazebo_gui-3] process has died [pid 6432, exit code 134, cmd /opt/ros/noetic/lib/gazebo_ros/gzclient __name:=gazebo_gui __log:=/home/araff/.ros/log/ed9e1bec-13ac-11eb-94b0-80ce6246ff47/gazebo_gui-3.log].

log file: /home/araff/.ros/log/ed9e1bec-13ac-11eb-94b0-80ce6246ff47/gazebo_gui-3*.log"

After which the process gets stuck. I've tried uninstalling ros and reinstalling, nothing seems to work. As a sidenote, when I try to simply run the command "gazebo", I don't get any error messages but nothing actually happens.

Contents of spawn.launch:

<?xml version="1.0" encoding="UTF-8"?>
<launch>
<!--Spawn empty world-->
<arg name="world" default="empty"/>
<arg name="paused" default="false"/>
<arg name="use_sim_time" default="true"/>
<arg name="gui" default="true"/>
<arg name="headless" default="false"/>
<arg name="debug" default="false"/>

<include file="$(find gazebo_ros)/launch/empty_world.launch">
<arg name="world_name" value="$(find ivr_lab)/worlds/myworld.world"/>
<arg name="paused" value="$(arg paused)"/>
<arg name="use_sim_time" value="$(arg use_sim_time)"/>
<arg name="gui" value="$(arg gui)"/>
<arg name="headless" value="$(arg headless)"/>
<arg name="debug" value="$(arg debug)"/>
</include>

<!--Spawn robot-->
<group ns="/robot">
    <param name="robot_description" command="$(find xacro)/xacro --inorder '$(find ivr_lab)/urdf/robot.urdf'"/>

    <arg name="x" default="0"/>
    <arg name="y" default="0"/>
    <arg name="z" default="0"/>

    <node name="my_robot_spawn" pkg="gazebo_ros" type="spawn_model" output="screen"
    args="-urdf -param robot_description -model my_robot -x $(arg x) -y $(arg y) -z $(arg z)" />

<!-- Load joint controller configurations from YAML file to parameter server -->
    <rosparam command="load" file="$(find ivr_lab)/config/joints.yaml" />

<!-- load the controllers -->
    <node name="controller_spawner" pkg="controller_manager" type="spawner"
            respawn = "false" output ="screen" ns="/robot"
            args="joint_state_controller
            joint1_position_controller
            joint2_position_controller
            joint3_position_controller
            --timeout 60">
    </node>

<!-- convert joint states to TF transforms for rviz, etc -->
    <node name="robot_state_publisher" pkg="robot_state_publisher" type="robot_state_publisher"
       respawn="false" output="screen">
       <remap from="/joint_states" to="/robot/joint_states" />
    </node>
</group>

<!--Spawn Camera-->
    <param name="robot_description" command="$(find xacro)/xacro --inorder '$(find ivr_lab)/urdf/camera.urdf'"/>

    <arg name="x" default="15"/>
    <arg name="y" default="0"/>
    <arg name="z" default="0"/>
    <arg name="roll" default="0"/>
    <arg name="pitch" default="0"/>
    <arg name="yaw" default="3.141592"/>

    <node name="my_camera_spawn" pkg="gazebo_ros" type="spawn_model" output="screen"
    args="-urdf -param robot_description -model my_camera -x $(arg x) -y $(arg y) -z $(arg z) -R $(arg roll) -P $(arg pitch) -Y $(arg yaw)" />

</launch>
edit retag flag offensive close merge delete

Comments

You'll need to post the package and content of spawn.launch to get help for why gazebo is crashing. If you don't want to do that, I recommend passing the --verboseflag to gazebo to see console output. https://answers.gazebosim.org//questi...

It might be helpful to launch gazebo in gdb to see where it's crashing #q47210

sloretz gravatar image sloretz  ( 2020-10-21 15:46:08 -0600 )edit

When I run gazebo --verbose I get the following errors and warnings:

[Err] [RenderEngine.cc:744] Can't open display:

[Wrn] [RenderEngine.cc:87] Unable to create X window. Rendering will be disabled

[Wrn] [RenderEngine.cc:287] Cannot initialize render engine since render path type is NONE. Ignore this warning ifrendering has been turned off on purpose.

[Wrn] [GuiIface.cc:119] could not connect to display

[Msg] Could not load the Qt platform plugin "xcb" in "" even though it was found.

[Err] [GuiIface.cc:123] This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.

ARaff gravatar image ARaff  ( 2020-10-22 12:34:06 -0600 )edit

when I try to simply run the command "gazebo"

Ah yeah, oops no need to look at the launch file. Something seems messed up with the machine. You might find more info from this question: https://askubuntu.com/questions/30812...

What's the output of QT_DEBUG_PLUGINS=1 gazebo --verbose?

sloretz gravatar image sloretz  ( 2020-10-22 19:13:34 -0600 )edit

Basically the [Guilface.cc:123] error from the previous comment, and the error message about reinstalling the application, though I have tried this already. Guilface.cc:111 works though. The output is too large to put in a comment and I don't have the permissions to add images, sorry

ARaff gravatar image ARaff  ( 2020-10-22 21:03:46 -0600 )edit