ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

Odom frame is shaking and jumping after fusing odometry with IMU

asked 2020-10-18 06:37:47 -0500

istvanbor gravatar image

Hello!

I have a question similar to this but that question died. So the situation is I have a four wheeled robot and I am calculating the wheel odom correctly and I want to fuse the yaw from an IMU. This IMU is currently my phone but I don't think it matters. I ran the 2 nodes separately and the tf turns (incorrectly) when the IMU is not present and vica versa.

Config file:

frequency: 30

silent_tf_failure: false

sensor_timeout: 0.01

two_d_mode: true

transform_time_offset: 0.0

transform_timeout: 0.0

print_diagnostics: true

debug: false

publish_tf: true

publish_acceleration: false

odom_frame: odom            # Defaults to "odom" if unspecified
base_link_frame: base_link  # Defaults to "base_link" if unspecified
world_frame: odom           # Defaults to the value of odom_frame if unspecified

odom0: /odom

odom0_config: [true,  true,  false,
               false, false, false,
               true, false, false,
               false, false, false,
               false, false, false]
odom0_queue_size: 2
odom0_nodelay: false

odom0_differential: false

odom0_relative: false

#odom0_pose_rejection_threshold: 5
#odom0_twist_rejection_threshold: 1


imu0: /imu0
imu0_config: [false,  false,  false,
           false, false, true,
           false, false, false,
           false, false, true,
           false, false, false]

mu0_nodelay: false
imu0_differential: false
imu0_relative: true
imu0_queue_size: 5
#imu0_pose_rejection_threshold: 0.8                 # Note the difference in parameter names
#imu0_twist_rejection_threshold: 0.8                #
#imu0_linear_acceleration_rejection_threshold: 0.8  #

imu0_remove_gravitational_acceleration: False

use_control: false
stamped_control: false

control_timeout: 0.2

acceleration_limits: [0.23, 0.0, 0.0, 0.0, 0.0, 0.23]

deceleration_limits: [0.23, 0.0, 0.0, 0.0, 0.0, 0.23]

acceleration_gains: [0.0, 0.0, 0.0, 0.0, 0.0, 0.0]

deceleration_gains: [0.0, 0.0, 0.0, 0.0, 0.0, 0.0]

 process_noise_covariance:
                                  [0.002, 0,    0,    0,    0,    0,    0,     0,     0,    0,    0,    0,    0,    0,    0,
                                   0,    0.002, 0,    0,    0,    0,    0,     0,     0,    0,    0,    0,    0,    0,    0,
                                   0,    0,    0.06, 0,    0,    0,    0,     0,     0,    0,    0,    0,    0,    0,    0,
                                   0,    0,    0,    0.03, 0,    0,    0,     0,    0,    0,    0,    0,    0,    0,    0,
                                   0,    0,    0,    0,    0.03, 0,    0,     0,     0,    0,    0,    0,    0,    0,    0,
                                   0,    0,    0,    0,    0,    0.002, 0,     0,     0,    0,    0,    0,    0,    0,    0,
                                   0,    0,    0,    0,    0,    0,    0.025, 0,     0,    0,    0,    0,    0,    0,    0,
                                   0,    0,    0,    0,    0,    0,    0,     0.025, 0,    0,    0,    0,    0,    0,    0,
                                   0,    0,    0,    0,    0,    0,    0,     0,     0.04, 0,    0,    0,    0,    0,    0,
                                   0,    0,    0,    0,    0,    0,    0,     0,     0,    0.01, 0,    0,    0,    0,    0,
                                   0,    0,    0,    0,    0,    0,    0,     0,     0,    0,    0.01, 0,    0,    0,    0,
                                   0,    0,    0,    0,    0,    0,    0,     0,     0,    0,    0,    0.02, 0,    0,    0,
                                   0,    0,    0,    0,    0,    0,    0,     0,     0,    0,    0,    0,    0.01, 0,    0,
                                   0,    0,    0,    0,    0,    0,    0,     0,     0,    0,    0,    0,    0,    0.01, 0,
                                   0,    0,    0,    0,    0,    0,    0,     0,     0,    0,    0,    0,    0,    0,    0.015]

initial_estimate_covariance: [1e-9, 0,    0,    0 ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-10-19 03:49:57 -0500

istvanbor gravatar image

Okay, my bad there was 2 TF sources. It's solved but I can't accept it.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2020-10-18 06:37:47 -0500

Seen: 337 times

Last updated: Oct 19 '20