Can't invoke catkin workspace on Raspbian Buster

asked 2020-09-26 12:50:46 -0500

Sassberry184 gravatar image

Hi all, just a newbie looking for some help. Recently I have started trying to set up ROS on Raspbian Buster for the Raspberry pi 3 B+, and have run into an error involving the workspace. I followed all the instructions on this page:

http://wiki.ros.org/ROSberryPi/Instal...

All have gone swimmingly up until step 3.3. When running the command:

sudo ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release --install-space /opt/ros/melodic

The return says this:

sudo: ./src/catkin/bin/catkin_make_isolated: command not found

I initially ran the command before going to the home directory, which a mechanical engineering friend of mine had advised me to do. If the return from that is necessary, please let me know, and I will post it. On running the command within the home directory, I get the error above. I have tried the following: 1. Running it in home directory 2. Running it and decreasing the compilation threadcount by adding -j2 to the end 3. Running just the command minus DCMAKE and everything after that. All result in the same error above. I also would be good to note that within the instructions linked above, I used the ROS Comm workspace commands.

Please help me to understand what is going on here, and how I can fix it. I also have the return from the attempt made in the different directory that I entered while in setup (please forgive my forgetting of this). If there is any more info needed, let me know and I will post it.

edit retag flag offensive close merge delete