Ask Your Question
0

Cannot install melodic on PYNQ Linux, based on Ubuntu 18.04 [arm]

asked 2020-09-25 02:18:12 -0500

Ariel gravatar image

updated 2020-09-25 03:37:35 -0500

Hello,

I am following the steps from the guide. However, when I run apt update I the following:

Hit:1 http://ports.ubuntu.com/ubuntu-ports bionic InRelease
Ign:2 http://packages.ros.org/ros/ubuntu glasgow InRelease
Err:3 http://packages.ros.org/ros/ubuntu glasgow Release
  404  Not Found [IP: 64.50.236.52 80]
Reading package lists... Done
E: The repository 'http://packages.ros.org/ros/ubuntu glasgow Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I followed this topic but that didn't solve the issue. I also added [trusted=yes] so my /etc/apt/sources.list.d/ros-latest.list looks like this:

deb [trusted=yes] http://packages.ros.org/ros/ubuntu glasgow main

However, I still have the same issue after running sudo apt update:

Hit:1 http://ports.ubuntu.com/ubuntu-ports bionic InRelease
Ign:2 http://packages.ros.org/ros/ubuntu glasgow InRelease   
Ign:3 http://packages.ros.org/ros/ubuntu glasgow Release     
Ign:4 http://packages.ros.org/ros/ubuntu glasgow/main all Packages
Ign:5 http://packages.ros.org/ros/ubuntu glasgow/main armhf Packages
Ign:6 http://packages.ros.org/ros/ubuntu glasgow/main Translation-en
Ign:7 http://packages.ros.org/ros/ubuntu glasgow/main Translation-en_US
Ign:4 http://packages.ros.org/ros/ubuntu glasgow/main all Packages
Ign:5 http://packages.ros.org/ros/ubuntu glasgow/main armhf Packages
Ign:6 http://packages.ros.org/ros/ubuntu glasgow/main Translation-en
Ign:7 http://packages.ros.org/ros/ubuntu glasgow/main Translation-en_US
Ign:4 http://packages.ros.org/ros/ubuntu glasgow/main all Packages
Ign:5 http://packages.ros.org/ros/ubuntu glasgow/main armhf Packages
Ign:6 http://packages.ros.org/ros/ubuntu glasgow/main Translation-en
Ign:7 http://packages.ros.org/ros/ubuntu glasgow/main Translation-en_US
Ign:4 http://packages.ros.org/ros/ubuntu glasgow/main all Packages
Ign:5 http://packages.ros.org/ros/ubuntu glasgow/main armhf Packages
Ign:6 http://packages.ros.org/ros/ubuntu glasgow/main Translation-en
Ign:7 http://packages.ros.org/ros/ubuntu glasgow/main Translation-en_US
Ign:4 http://packages.ros.org/ros/ubuntu glasgow/main all Packages
Ign:5 http://packages.ros.org/ros/ubuntu glasgow/main armhf Packages
Ign:6 http://packages.ros.org/ros/ubuntu glasgow/main Translation-en
Ign:7 http://packages.ros.org/ros/ubuntu glasgow/main Translation-en_US
Ign:4 http://packages.ros.org/ros/ubuntu glasgow/main all Packages
Ign:5 http://packages.ros.org/ros/ubuntu glasgow/main armhf Packages
Ign:6 http://packages.ros.org/ros/ubuntu glasgow/main Translation-en
Ign:7 http://packages.ros.org/ros/ubuntu glasgow/main Translation-en_US
Ign:4 http://packages.ros.org/ros/ubuntu glasgow/main all Packages
Err:5 http://packages.ros.org/ros/ubuntu glasgow/main armhf Packages
  404  Not Found [IP: 64.50.233.100 80]
Ign:6 http://packages.ros ...
(more)
edit retag flag offensive close merge delete

Comments

I've also updated the title of your question, so as to better reflect your situation.

You're not just running Ubuntu 18.04, but a derived distribution, based on it.

That changes things.

gvdhoorn gravatar image gvdhoorn  ( 2020-09-25 03:34:55 -0500 )edit

EDIT: The issue seems to be with the codename for the custom linux distribution. Therefore, editing /etc/lsb_release to include as codename bionic seemed to work.

it's up to you, but I would not edit system files like that. lsb_release is managed by apt, so next time there is an update, your edit will be reverted.

gvdhoorn gravatar image gvdhoorn  ( 2020-09-25 03:40:26 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2020-09-25 03:31:47 -0500

gvdhoorn gravatar image

updated 2020-09-25 03:38:04 -0500

Codename:       glasgow

This is the problem.

glasgow is not an Ubuntu codename for 18.04. It's likely the name PYNQ Linux uses for its distribution.

If you are certain Ubuntu 18.04 packages are compatible with this derived distribution, then you'll need to replace that by bionic, everywhere it occurs in your /etc/apt.d/ros1-latest.list.

That would make apt download indices for bionic instead, which is a recognised codename for 18.04.

Then, for any future invocations of rosdep, you'll need to add --os=ubuntu:bionic. And you'll want to set the ROS_OS_OVERRIDE environment variable to ubuntu:18.04:bionic as well (note: you'll have to do this in all (future) shell sessions, so you may want to add it to your .bashrc).

edit flag offensive delete link more

Comments

Yes, I directly changed the /etc/lsb_release to have bionic but your way is safer I believe.

Ariel gravatar image Ariel  ( 2020-09-25 04:19:03 -0500 )edit
0

answered 2020-09-25 02:27:39 -0500

Nitesh_j gravatar image

Can you be more specific, Which SBC is using? or which OS are you installing at

edit flag offensive delete link more

Comments

I am using a Pynq board, Ubuntu 18.04. I edited my question.

Ariel gravatar image Ariel  ( 2020-09-25 02:33:38 -0500 )edit

can you try this link text and let us knw

Nitesh_j gravatar image Nitesh_j  ( 2020-09-25 02:43:59 -0500 )edit

What is the difference then between UbuntuARM and Ubuntu (the one you suggested)? I believe I should use the one meant for arm.

Ariel gravatar image Ariel  ( 2020-09-25 02:52:19 -0500 )edit

Ubuntu packages are built for the following distros and architectures.

Distro

amd64

arm64

armhf

It is mentioned in the above page , for which distros and architectures it supports plz go through the page and let us know

Nitesh_j gravatar image Nitesh_j  ( 2020-09-25 03:26:05 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-09-25 02:18:12 -0500

Seen: 40 times

Last updated: Sep 25