Ask Your Question
1

GTest not found [closed]

asked 2012-06-11 06:23:55 -0500

Jonas Koenemann gravatar image

updated 2012-06-11 06:24:54 -0500

Hi!

I am trying to get my project to work with GTest. It is with ROS fuerte. I added the following line to the CMakeLists:

rosbuild_add_gtest(test/model test/model.cpp)

While building the project i get the error:

[rosbuild] Including /opt/ros/fuerte/share/roslisp/rosbuild/roslisp.cmake
CMake Warning at /opt/ros/fuerte/share/ros/core/rosbuild/public.cmake:595 (message):
  GTest not found; C++ tests will fail to build.
Call Stack (most recent call first):
  /opt/ros/fuerte/share/ros/core/rosbuild/private.cmake:124 (rosbuild_add_gtest_build_flags)
  /opt/ros/fuerte/share/ros/core/rosbuild/public.cmake:625 (_rosbuild_add_gtest)
  CMakeLists.txt:34 (rosbuild_add_gtest)

This not only happens when i build my own package but also when i try to build a fuerte package.. I have Ubuntu Version 10.04 and libgtest is installed in /usr/lib and /usr/include.

Do you have any advice?

Thanks!

Jonas

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2012-09-15 22:00:13

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-06-11 08:41:54 -0500

Lorenz gravatar image

Did you install libgtest-dev?

sudo apt-get install libgtest-dev
edit flag offensive delete link more

Comments

yes: ~$ dpkg -s libgtest-dev Package: libgtest-dev Status: install ok installed

Jonas Koenemann gravatar image Jonas Koenemann  ( 2012-06-11 15:05:43 -0500 )edit

Question Tools

Stats

Asked: 2012-06-11 06:23:55 -0500

Seen: 1,126 times

Last updated: Jun 11 '12