[Navigation] move_base not responding to nav goals being sent

asked 2020-09-14 09:07:45 -0600

conorbc gravatar image

Hey, can and will provide information as it is helpful. Fairly certain my tf tree is setup right, and I believe I have covered everything in my launch file from the ros navigation stack tutorial and everything launches without error, I can see the map in RViz with my bot. When I create a nav goal though nothing happens. The move_base node never publishes anything on the /cmd_vel topic.

When I echo /cmd_vel and some others I get:

"WARNING: no messages received and simulated time is active.

Is /clock being published?" (I am running gazebo and that publishes /clock, and I can confirm that with a rostopic echo)

Anyone have any idea where the disconnect would be?

Things I have looked into and tried:

  • move_base is subscribed to /move_base_simple/goal
  • move_base is set to publish on /cmd_vel
  • I can send my own cmd_vel commands fine that isn't in question
  • I tried rostopic pub /move_base/goal move_base_msgs/MoveBaseActionGoal "header:...
  • no success publishing the goal manually on that topic
  • I don't see any disconnects on rqt_graph or the tf tree that would worry me.

I cant upload images, but you can check out my tf tree and rqt_graph output on my reddit post on the topic; https://www.reddit.com/r/ROS/comments...

Any help would be greatly appreciated, I am just kind of at a loss for where to go next in debugging.

edit retag flag offensive close merge delete


are you able to visualize the local_costmaps in rviz. The obstacles and the inflation radius are all showing up properly? Cause when I look at your rqt_graph, move_base is not publishing anything. Specifically, the topics: 1. move_base/obstacles 2. move_base/inflated_obstacles 3. local_costmap/unknown_space are not showing up And also other topics like TrajectoryPlanners etc...are not showing up. Have you referred to this link: using Rviz with Navigation Stack

Lastly, did you resolve this issue, if yes, how? Because I'm facing the same problem. Thanks

pk99 gravatar image pk99  ( 2021-04-22 09:55:19 -0600 )edit

He seemed to solve it but the answer is here.

Hope it helps you.

Ronro gravatar image Ronro  ( 2021-08-15 06:49:24 -0600 )edit