Ask Your Question
0

rtabmap Tutorial. Odometry Died On Startup. (Noetic, Xtion, U20.04, Beginner)

asked 2020-09-11 21:28:55 -0500

Augustus gravatar image

Brief Introduction — I'm learning ROS for the third time in my life: first Groovy, then Jade. At first I tried Foxy but I didn't see any obvious way to get mapping with an Xtion. Now I'm attempting to get rtabmap working with Noetic. Although I've used ROS in several projects, I'd still classify myself as a beginner. I'm mostly interested in the practical result of a point cloud, so if there are other SLAM packages comparable to rtabmap, I'd be willing to try them. I've been stuck here for hours, any help will be greatly appreciated.

My Problem — At the moment I'm following the rtabmap_ros tutorial "RGB-D Handheld Mapping" with an Xtion Pro. I am given this error after initializing but before the GUI appears.

[ INFO] [1599872946.228008583]: Setup depth callback [rtabmap/rgbd_odometry-1]

process has died [pid 6785, exit code -6, cmd /opt/ros/noetic/lib/rtabmap_ros/rgbd_odometry rgb/image:=/camera/rgb/image_rect_color depth/image:=/camera/depth_registered/image_raw rgb/camera_info:=/camera/rgb/camera_info rgbd_image:=rgbd_image_relay odom:=/odom imu:=/imu/data __name:=rgbd_odometry __log:=/home/aug/.ros/log/d90a0fe6-f490-11ea-a0cb-6b5fc5d13082/rtabmap-rgbd_odometry-1.log]. log file: /home/aug/.ros/log/d90a0fe6-f490-11ea-a0cb-6b5fc5d13082/rtabmap-rgbd_odometry-1*.log

The GUI then appears but nothing happens. The previously launched openni2 terminal then seems to properly stream data out.

[ INFO] [1599871743.342685883]: Starting color stream.

[ INFO] [1599871743.409124586]: Starting depth stream.

[ INFO] [1599871743.766569060]: using default calibration URL

[ INFO] [1599871743.766710232]: camera calibration URL: file:///home/aug/.ros/camera_info/rgb_PS1080_PrimeSense.yaml

[ INFO] [1599871743.885914291]: using default calibration URL

[ INFO] [1599871743.886016169]: camera calibration URL: file:///home/aug/.ros/camera_info/depth_PS1080_PrimeSense.yaml

This is followed by a constant stream of these two warnings from the rtabmap terminal.

[ WARN] [1599872971.264661933]: /rtabmap/rtabmap: Did not receive data since 5 seconds! Make sure the input topics are published ("$ rostopic hz my_topic") and the timestamps in their header are set. If topics are coming from different computers, make sure the clocks of the computers are synchronized ("ntpdate"). If topics are not published at the same rate, you could increase "queue_size" parameter (current=10). /rtabmap/rtabmap subscribed to (approx sync): /odom, /camera/rgb/image_rect_color, /camera/depth_registered/image_raw, /camera/rgb/camera_info, /rtabmap/odom_info

[ WARN] [1599872951.263666547]: /rtabmap/rtabmap: Did not receive data since 5 seconds! Make sure the input topics are published etc...

Troubleshooting — Started with with trying to trigger a new map or reset the odometry. I do not know why odometry seems to be failing, there is no robot to get odometry from.

  • Next I went to look for the log file, but I saw no files named "rtabmap-rgbd_odometry-1*.log"
  • Then I checked the topics and everything seemed to be there and correct. *Topics listed bellow...
  • To verify the sensor was indeed working I ran rqt. The RGB and Depth video feeds were visible, so that's good.
  • Then I checked the forums for some advice, and discovered that building rtabmap from binaries tends to fix some issues. So I tried this but the result is ...
(more)
edit retag flag offensive close merge delete

Comments

The node rtabmap_ros/rgbd_odometry is crashing on start. I see you are using the binaries /opt/ros/noetic. I am not able to reproduce the error in my VM Noetic. Is the standalone working (type $ rtabmapin terminal)? Can you try also the basic demo http://wiki.ros.org/rtabmap_ros#Robot... ? Are you on an intel computer?

matlabbe gravatar image matlabbe  ( 2020-09-15 17:21:50 -0500 )edit

rtabmap works, and I am able to run the bag file demos but with some inconsistencies. It usually runs, but on occasion I get a *** buffer overflow detected ***: terminated error. When things do work, I am able to get to the Done. line of the bag.

My CPU is an "Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz" running on a laptop. I have had a SLAM package working on a lesser machine, so I believe this should make the cut.

So, at the moment I am getting an error on boot from Ubuntu saying that rgbd_odometry stopped working. Additionally I was unable to get output from Rviz, but I believe that's a tf issue. It has been a while since I needed to setup frames.

On occasion my terminals will all crash when running rtabmap and it's super frustrating to reset all terminals. I am able to ...(more)

Augustus gravatar image Augustus  ( 2020-09-19 15:11:18 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2020-09-19 17:38:57 -0500

Augustus gravatar image

I was able to get rtabmap working, but the solution is not glamorous. I purged and started over and it worked flawlessly, something I did broke my rgbd_odometry. For those curious of the steps I took to reinstall and setup...

Remove:

$ sudo apt-get purge ros-*

$ sudo apt-get purge python-ros*

$ sudo apt-get autoremove

Install noetic

Install ros-noetic-rtabmap-ros

Install Xtion Live with openNI2

$ sudo apt-get install ros-noetic-rgbd-launch ros-noetic-openni2-camera ros-noetic-openni2-launch

$ sudo apt-get install ros-noetic-rqt ros-noetic-rqt-common-plugins ros-noetic-rqt-robot-plugins

Finally follow the instructions in the tutorial

P.S. thanks @matlabbe for verifying it should work.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-09-11 21:28:55 -0500

Seen: 112 times

Last updated: Sep 19 '20